Lsusb not showing device information - OpenWrt 19

I recently ported from OpenWrt 13 to OpenWrt 19.7.06. In OpenWrt 13 when I ran lsusb I get the following output

When I use the same command in OpenWrt 19 I get the following output.
I even tried with -v -t -s options, but result is the same. Please help me to get similar output as in OpenWrt 13.

I also added the USB drivers in build under Kernel Module-->USB Support

Stock shows

root@OpenWrt0:~# lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 017: ID 1949:03a8 Lab126, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

If your output is different, you're probably still missing modules.

when I installed lsusb on my openwrt it also installed

1 Like

I'm actually generating a bin image due to size limitations. I will try to add those two modules as well and see. Thanks

librt and libusb is already included. Any idea which specific module will fix this?

1 Like

I cannot use opkg install, Instead I added all these via menuconfig utility while building the image.

1 Like

The names are in the usbids package. This is a 700 kB text file, though being text it is going to squash to much less than that.

Selecting usbutils will install the dependencies like usbids, but it is likely going to be a problem with limited flash space.

1 Like

Thank you so much. The issue was usbutils not added to the build. I actually added lsusb from base system --> BusyBox--->Cutomize Busy Box option --> Linux System Utilities ---><*>lsub, I disabled this and added it from Utilities --> usbutils and rebuilt the image. Now its working.

It doesn't seem to exist:

Moreover, the OP already used lsusb which is part of usbutils as well as usb.ids:

# opkg files usbutils
Package usbutils (007-10) is installed on root and has the following files:

This means the package was installed from the beginning.
So, the cause of the issue should be somewhere else.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.