Lost internet connection after configuring working IPTV

Hi eveyone,
I connect to ISP by Ethenet cable on Wan port of openwrt router (Netgear WAX202 with 1 WAN and 3 LAN ports).
Default configuration works well with PPPOE Wan connection to internet. And the default configuration is as follows:

/etc/config/network is

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd2d:e572:5689::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config device
	option name 'lan1'
	option macaddr '34:98:b5:12:f1:5c'

config device
	option name 'lan2'
	option macaddr '34:98:b5:12:f1:5c'

config device
	option name 'lan3'
	option macaddr '34:98:b5:12:f1:5c'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr '34:98:b5:12:f1:5d'

config interface 'wan'
	option device 'wan'
	option proto 'pppoe'
	option username 'xxxxxxx'
	option password 'xxxxxxx'
	option ipv6 'auto'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

I tried to configure IPTV on the router, my ISP only requires a special VLAN ID 103 on port that STB is connected. No igmproxy or other requirements.
I decided to connect STB (ISP provided IPTV box) on port 3 so I excluded port 3 on default br-lan bridge device.


Then created a new bridge device called br-iptv with lan3 and wan port , addeed VLAN with ID 103.


Finnaly created an interface for IPTV called WANIPTV using br-iptv

Final devices and interfaces are as follows


and the /etc/config/network is

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd2d:e572:5689::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'

config device
	option name 'lan1'
	option macaddr '34:98:b5:12:f1:5c'

config device
	option name 'lan2'
	option macaddr '34:98:b5:12:f1:5c'

config device
	option name 'lan3'
	option macaddr '34:98:b5:12:f1:5c'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr '34:98:b5:12:f1:5d'

config interface 'wan'
	option device 'wan'
	option proto 'pppoe'
	option username 'xxxxxxxx'
	option password 'xxxxxxxx'
	option ipv6 'auto'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config device
	option type 'bridge'
	option name 'br-iptv'
	list ports 'lan3'
	list ports 'wan'

config bridge-vlan
	option device 'br-iptv'
	option vlan '103'
	list ports 'lan3:u*'
	list ports 'wan:t'

config interface 'wanIPTV'
	option proto 'dhcp'
	option device 'br-iptv'

With this configuration IPTV works perfect but , WAN connection drops on lan1 and lan2.

What may be the problem? Thanks for the help in advance.

Since the wan physical port is now in a bridge, it can't also be accessed directly by the pppoe driver with the option device wan which is still configured there.

Create another bridge-vlan inside br-iptv for the router Internet wan traffic. It can have any vlan number (other than 103 of course)-- I suggest 2 as that is conventional for wans. It should be untagged on the wan port, which is connected to the modem. Then change the device of the wan (and wan6, if you are using IPv6 that way) interface(s) to br-iptv.2.

Thank you very much , it works now.
Should I choose a firewall zone for the newly created WANIPTV interface or leave it as it is?.

Delete the WANIPTV interface, you don't need it at all(*). The TV packets should be switched by hardware within br-iptv-- they never go to the OpenWrt kernel.

  • If deleting the interface stops TV from working, create a new one of protocol none (Unmanaged) and Device br-iptv.103. That may be needed to actually start up the hardware switching. An Unmanaged interface never has an IP address so it does not need a firewall zone.

After deleting WANIPTV interface all still works fine.
Thank you very much.

Again thanks for helping and I have one more small question if you don't mind :blush:.
Can all this be done without creating a new bridge and VLANS on it and without touching default br-lan bridge ? I mean wan.103 and lan3.103 VLANS or some other things may be? (I tried but not succeeded actually :wink:).

Thanks again, have a great day.

Hardware switching (or any linking) of tagged ports seems to only work if both ports are in the same bridge and also a bridge-vlan.

In other words something like this does not work.

config device
   option name 'br-tv'
   option type 'bridge'
   list ports 'lan1.103'
   list ports 'wan.103'

It's theoretically possible to reuse the same vlan number in two independent bridges associated with the same hardware switch, but it could also cause problems.

Thank you.

Hi again,

With the above configuration iptv and internet acces works well but , STB freezes after about 24 hours and does not respond to remote control device commands then needs to be hard booted (this never happens when STB is coonected to the ISP's original router so I can't blame STB equipment :slightly_smiling_face:). Is there any thing to be done to overcome this? Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.