Lost connectivity changing the lan ip address of the OpenWrt router to a different subnet

Hello, I bought a BT hub 5 with Luci openwrt 18.06.2 pre-installed. I am trying to change the subnet to 192.168.0.1 from the default 192.168.1.1as I’m using the openwrt routers wireless as client to an already existing access point which uses the same 192.168.1.0 subnet (I believe I’m using it as a bridge). When I change the lan interface’s ip address of the openwrt router to 192.168.0.1, I also set my Windows 10 Ethernet nic address to a static address of 192.168.0.101/24 and the gateway address and dns to 192.168.0.1, I cannot connect to the openwrt router and I lose network connectivity ( no internet ) which I had before. I have to reset the openwrt router back to factory as I connect access the interface.

Is there something I’m not doing that I should be doing?

Any help would be much appreciated. :pray:

So make the change as usual, click save and apply and whilst it’s applying unplug and replug in your Ethernet. Wait 30 seconds, unplug and replug again. The web interface will then show that the change has rolled back, click the red button to apply anyway. Unplug and replug Ethernet, go to your new LAN IP (192.168.0.1) and it should work. (Forgot to add, tell your computer to automatically obtain the IP’s for this to work)

This is a relatively easy way to get around the web interface trying to check the changes have been applied but it can’t because of the LAN IP change. Either this or change it by command line instead.

2 Likes

Thanks,

I ended up doing the changes to the lan interface IP address first before setting up the wireless client connection, then I got a message asking to “apply unconfirmed” which I never saw before I’ve just done this a few minutes ago and it’s worked. I can access the interface now without any issues. I think this is a bug in the current Luci build.

How do I report a bug? Cause there’s another’s bug I experienced beforehand when setting up wireless as a client.

That is normal behaviour IMO. Lan and wan might have different properties/subnets etc.

1 Like

It isn't really a bug. Apply the change, sit tight until the roll back window pops up, click "Apply Anyway". At this point the router will be operating with the new address. Disconnect and reconnect your PC so that it does another DHCP, then type the new address into the browser.

When you are getting Internet through a wifi client on the WAN side in a different IP range than your LAN, that is called a routed client not bridged.

2 Likes

@mk24 @h8red ok thanks for your help, it’s sorted now :pray:, so if the wan is connected to a subnet 192.168.1.0 and the lan subnet is 192.168.1.0 there wouldn’t have been any clashes if the gateway on the router I’m connecting to as the wan had the same ip address as the openwrt router in using as routed client?

I was following this guys YouTube video , he changed the subnet without any problems while setting up a wireless bridge. (https://youtu.be/-Vi91fTqsEU)

I like openwrt I wish more tutorials was around :sweat_smile: or like an in-depth online course/walk through.

2 Likes