Loss of internet after initializing VPN

I'm using 21.02 FW and downloaded the OVPN config file from Nord, put my credentials in and got the VPN to start. As soon as the VPN starts, I lose internet connection. I can still Ping out from what I'm seeing under Network=>Diagnostics but pulling up webpages isn't running normally. I have attempted to add the VPN interface as well as set the WAN zone in Firewall settings to tun0. I'm new to all this so I've been using the LEDE interface rather than command line.

For what it's worth, with VPN disabled, normal internet. With VPN enabled, no internet when connected to the POE brick or wirelessly.

It is better to discuss in PM, write me, if you wish.

Probably a dns issue.. try using a custom dns server on your lan interface.



If you followed that advice, please post the solution if you have an opportunity - as I'm curious to know how it was fixed. I'm sure someone else who searches and finds this thread would be grateful too.


Let's discuss here so that others can have the same question answered.

1 Like

Changing the DNS servers had no beneficial effect. When VPN is activated, I lose internet yet still can ping addresses and get back good results as seen in the picture.

I'm getting this when VPN is disabled: Error: Unknown error (DEVICE_CLAIM_FAILED)

When VPN is enabled it is showing some info being passed as seen in this screenshot:

I changed the DNS for the VPN and the VPNS interfaces too, with no luck getting online yet still being able to ping.

Can you ping the same IP from PC, connected to LAN?

Waiting 10 min to answer, no answer, although there is typing notification. OK, good luck!

Solved!! I went back into Network=> Firewall => Zones => WAN => Edit => Advanced Settings => Covered Devices=== and selected: Ethernet Adapter: "tun0" (VPN)

As I expected, it was your problem, not problem of OpenWRT. One question has solved the problem.

Congratulations, now all people know, that you are noob. Very valuable information.

You bring nothing to the table.

You solved nothing.

Yes, I have a life outside of OpenWRT. You should try it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.