Looking for help about VLAN tagging

Hi guy i have some question
I'm new to openwrt
My ISP Require Pppoe and Vlan tagging for internet(vlan 60) and iptv (vlan10)
now my internet working fine but iptv not

here it's my config , I try to setting Lan Port 4 to Vlan 10


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd35:06dd:d49a::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1.1'

config device
	option name 'eth1.1'
	option macaddr '******'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipv6 'off'
	option ipaddr '192.168.88.1'
	list dns '192.168.88.40'

config device
	option name 'eth0.2'
	option macaddr '60:31:97:3e:84:b7'

config interface 'wan'
	option proto 'pppoe'
	option device 'eth0.60'
	option username '*********'
	option password '*********'
	option peerdns '0'
	list dns '9.9.9.9'
	list dns '1.0.0.1'
	option ipv6 'off'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '6t 1 2 3'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5t'
	option vid '60'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '10'
	option ports '4t'


and this is my Switch page

and this is working config from my old asus router

any idea?
Sorry for my bad eng :slight_smile:

You have both CPUs set to 'off' for VLAN 10, meaning none of the data actually gets processed.

Actually the TV packets don't need to go to a CPU. But you do need to have them tagged to the WAN port. The TV box on port 4 will then hardware switch to the modem on port WAN (5). The CPU receives and processes VLAN 60 packets for Internet use but it needn't care what the TV box is sending to or from the ISP on VLAN 10.

Right now VLAN 10 has only one member in the switch, so packets from the TV box go in but there is no other port to send them out.

In the OEM firmware it is implicit that all the ISP-related VLANs will be switched and tagged to the WAN port. In OpenWrt you need to do that by selecting them in the column under WAN.

4 Likes

should i add another wan port ?

No, you just need the tagged packets to go to the modem on the existing port. The link from the router's WAN port to the modem will be sending Internet on VLAN 60, and TV on VLAN 10, on the same cable.

On the switch page, in the column under WAN, in the row for VLAN 10, change that setting from Off to Tagged. Then it should work.

2 Likes

Still not working
What did i do wrong

Compared to the previous post, you've also set LAN 4 to untagged in VLAN 1. That is wrong. Change it back to off. The only thing going to the TV box should be VLAN 10 packets from the modem.

Confirm the TV box is on port 4 by unplugging its cable and observe that the icon under LAN 4 changes from cable plugged in to no link.

It is possible that the TV box expects untagged packets, in that case you would change VLAN 10 on LAN 4 from tagged to untagged. If the box uses tagged packets you should be able to plug it directly to the modem on modem port you now have connected to WAN, and TV will work. Internet would of course be disconnected while doing that. If the box does not work connected directly to the modem there is something else going on.

i upload wrong image sorry
Tv box is on port 4 for sure because i try to unplug lan cable and lan port 4 icon change to nolink

my current setting still no luck but i keep trying.

Mark lan4 port as untagged and try again. I'm not sure that your TV box understand tagged traffic.

1 Like

found solution with weird method
just update openwrt to snapshot 22
and now everything work great

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.