Login not redirecting to HTTPS

Hi, i've installed a luci-ssl plug in order to have a SSL Login support. When i write the router IP to login the page wont automatically redirect from HTTP to HTTPS. If i manually add the "https://routerip" it works. So only do not redirect automatically. I had try to reinstall luci and after luci-ssl but the issue persist. Suggestions? Thanks

Do you have the line option redirect_https 1 in the file /etc/config/uhttpd ?

Have you restarted the uhttpd daemon? (Restarting the daemon generates the encryption keys used for https.)

2 Likes

I messed up with uhttpd. I tried to install the certificate to avoid the "cert autosigned" warning on the browser but I was left out of LuCi. I restored access by re-installing LuCi via cmd. Now the GUi works but maybe some problems remained. However the "option redirect_https" option was set to 0. Now I set it to 1 and it works. Is there an easier way to install and use a non self-signed certificate? In order to avoid the warning on the browser. Thank you.

3 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.