Logging with no root account but after logining it turn out to root

As the pic show,I try to loggin by ssh with a account which is not root.But after logining,it becomes root account.I have tried to create a new user.But it doesn't work.What's the problem with my router?

Openwrt has one user setup by default: root. Everything is fine.

But I have create a new user by myself.Actually it works in the begining.But I suddenly found it doesn't work two days ago when i try to login again.

How did you create the new user?

EDIT: and why? What do you want to achieve with another user on OpenWrt?

Kick up verbosity to check negotiation ssh -vvv progress. Key in the user home given that it worked once?

use opkg to install useradd command..
I follow this website to create a new user.And I just need a user account which cannot change some important file,but can use python normally.

It work will in the past actually.I have try use -vvv,but it seems that there are not some useful information.

What UID / GID did you assign to that user? How is it defined at "/etc/paswd"?

UID and GID both are 1000. In /etc/passwd/,it is defined : rootaux:x:1000:1000::/home/rootaux:/bin/ash.

Thas is weird... I do not see how could this be happening.

If you create a file and use the ls -n option to get numeric user / group id what does it show?

It could be that whoami is broken.