Loco M2 2 wifi and 2 vlan

Hi everyone,

I have a little problem with vlan setting.
The target device is a NanoStation Loco M2 access point.
It has 1 LAN connector.
I managed to create the multi ssid signal.
I attached it to a separate vlan device.
Then I put it in a bridge connection. I disabled the tagged and untagged process there.
The DHCP server comes from an external source via the Trunk.
Unfortunately, the connected clients do not receive an IP address.

Where did I screw up?

network config file

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.10.146'
        option netmask '255.255.255.0'
        option gateway '192.168.10.254'
        option device 'eth0'
        list dns '192.168.10.254'

config device
        option type '8021q'
        option ifname 'eth0'
        option vid '2'
        option name 'WorkVlan'

config device
        option type '8021q'
        option ifname 'eth0'
        option vid '3'
        option name 'GuestVlan'

config device
        option type 'bridge'
        option name 'Bridge'
        list ports 'eth0'
        list ports 'GuestVlan'
        list ports 'WorkVlan'

config bridge-vlan
        option device 'Bridge'
        option vlan '1'
        list ports 'eth0'
        list ports 'GuestVlan:t'
        list ports 'WorkVlan:t'

config bridge-vlan
        option device 'Bridge'
        option vlan '2'
        list ports 'GuestVlan'

config bridge-vlan
        option device 'Bridge'
        option vlan '3'
        list ports 'WorkVlan'

config interface 'Work'
        option proto 'none'
        option device 'WorkVlan'
        option type 'bridge'

config interface 'Guest'
        option proto 'none'
        option device 'GuestVlan'

wireless config file


config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'
        option txpower '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option encryption 'none'
        option ssid 'Work'
        option network 'Work'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid 'Guest'
        option encryption 'none'
        option network 'Guest'

Don't use bridge-vlans on a device that doesn't have a DSA switch. Make a separate bridge for each network. Also it's a good idea to have at least a temporary AP bridged to lan so that you can log in if Ethernet does not work.

How do I manage Vlan switches? :upside_down_face: :sweat_smile:

Here's an example.
Correct the VLAN IDs if necessary

...

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.10.146'
        option netmask '255.255.255.0'
        option gateway '192.168.10.254'
        option device 'eth0'
        list dns '192.168.10.254'

config device
        option name 'br-work'
        option type 'bridge'
        list ports 'eth0.2'

config interface 'Work'
        option proto 'none'
        option device 'br-work'

config device
        option name 'br-guest'
        option type 'bridge'
        list ports 'eth0.3'
        
config interface 'Guest'
        option proto 'none'
        option device 'br-guest'
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.