Linsys WAP4410N problems with partitions

Hi all! Can anyone help me with fixing issues with partitions?

I have an error:
[ 0.368037] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[ 0.375627] Please append a correct "root=" boot option; here are the available partitions:
[ 0.384036] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[ 0.395815] ---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I used command to flash linksys router from stock firmware as described here

erase 0xbf050000 0xbf7cffff

tftpboot 0x81000000 openwrt-ar71xx-generic-uImage-gzip.bin cp.b 0x81000000 0xbf050000 $filesize (tftpboot tells you this)

tftpboot 0x81000000 openwrt-ar71xx-generic-root.squashfs cp.b 0x81000000 0xbf1e0000 $filesize

setenv bootargs console=ttyS0,115200 init=/sbin/init board=WAP4410N mem=32M setenv bootcmd
bootm 0xbf050000

It seems like there is no partition for rootfs file system, but kernel does start.

I tried commands to point the partitions such as:
setenv mtdparts mtdparts=ar9100-nor0:2048k(uImage),6144k(rootfs), but it doesn't work and I have the same error.

but the issuing command ls / gives me another response and tried to scan JFFS2 partition. It is strange, because I put an squashfs image.

Scanning JFFS2 FS: done.
ar7100> mtdparts

device nor0 , # parts = 2
#: name size offset mask_flags
0: rootfs 0x00400000 0x00000000 0
1: uImage 0x00200000 0x00400000 0

active partition: nor0,0 - (rootfs) 0x00400000 @ 0x00000000

mtdids : nor0=ar9100-nor0
mtdparts: mtdparts=ar9100-nor0:4096k(rootfs),256k(u-boot),128k(u-boot-env),1024k(uImage)

Perhaps, my mtdparts command is not correct and initially it was not any mtdparts variables at all and even ls / command did not work. Anyway, should I issue this command by myself at all?

Thanks to all.