Linksys WRT32X

Hello all,
I've searched the forum and there seems to be a lot of threads related to WRT32X and it's cousin the 3200ACM. I hope that I am correct in saying that most of these threads seem to refer to getting the 3200ACM builds to work on WRT32X before WRT32X support was "officially" added to LEDE/OpenWRT.

I have downloaded the 18.06-RC2 as well as davidc502's (Build = r7493)

Before I attempt to flash anything I have the following questions which I hope you guys can help me with:

  1. Do I flash through the normal route i.e. flash the bin file as if it were Linksys' ROM?
  2. There are two bin files, Factory and Sysupgrade. Which do I use and why?
  3. There was mention of 2 partitions which leads me to believe that LEDE could potentially run on another partition allowing the switching between Linksys's firmware and LEDE/OpenWRT. Is this correct?
  4. If yes, how do I install LEDE/OpenWRT while keeping the original firmware? Is there a specific method?

If the above is mostly incorrect, what would be the best way to get either the RC2 or Davidc502 builds on the WRT32X while maintaining a route back to the original firmware and what are the latest bugs to be aware of?

Thank you in advance.

In the future, you may want to notify him by doing this: @davidc502

Since I don't have your exact device, I can only help you with this question. Factory images are designed to work to flash from OEM stock firmware to OpenWrt. Sysupgrade is used to upgrade on a device already running OpenWrt.

There is also the FAQ --

Thank you both very much.

@davidc502, do you know if your latest image had newer drivers than 18.06.0-rc2 as well?

It's hard to say for sure without going through commits, but rc2 probably has the same driver or earlier.

@davidc502 Hi David. I recently purchased a preowned WRT32X ($50); been trying to install openwrt. Upload .img file but it does nothing. Just populates with name. I disabled ad/popup blocker on Chrome, Brave and Edge. Even tried in private window using browsers. Any suggestions? I am stumped!

Also tried setting up VPN on the factory fw; only allows me to upload an openvpn file. I use Torguard w/wineguard.

@davidc502 stopped building firmware for these routers a couple of years ago.

There are a couple of community builds you might want to look at:
or And the repo at:

I have used Divested and I can vouch for it. It’s solid.

I have not used Purefusion so can only comment that it was an active forum.

I am still subscribed, but have not been involved in OpenWrt in several years.
Just keep in mind, the router has 2 flash bins, so you can always go back to factory.

Best Regards,

Really good to see you still checking in David. Your build/forum taught me everything I needed to continue building based on your config.buildinfo post DSA. Thank You,

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.