Linksys wrt320n as repeater of iPhone hotspot

Linksys wrt320n with the latest openwrt firmware ( Firmware Version

OpenWrt 18.06.2 r7676-cddd7b4c77 / LuCI openwrt-18.06 branch (git-19.020.41695-6f6641d))
Could I use my linksys wrt320n as repeater(extender) of the wifi signal or not?
I have the similar problem as here: Linksys WRT320N - no Wifi after adding guest WLAN

When I enable Master wifi to share iPhone wifi, iphone wifi is is not associated
Maybe you know other variants how to repeat(extend) iphone hotspot with Linksys wrt320n

Thank you.

This is a different case, so probably best to leave it alone for now.

Before you enable Master WiFi, do you have your router associated with phone WiFi? Do you have internet access on your router?

After you have confirmed that your router gets internet form your phone, for repeating or extended internet to router clients, look for Travelmate

Thank you for your help. Yes, it's working well in this situation.

How to install this firmware? It's separate firmware or like addon?

it's a package. With the router having internet connection:

  1. Go to (or whatever the IP is).
  2. Update the packages list
  3. Search for Travelmate
  4. Install travelmate and luci-app-travelmate

Great. Thank you for your help!

The problem, that I have only internet with my iPhone hotspot.
Now I need to connect the router to this hotspot, right?
But, I have this situation.


*** Failed to download the package list from

How to solve it?

I thought you said you have internet on the router

I can connect the iphone to my PC via cable or wifi.
I can connect router to PC.
Maybe router can get internet access from lan (router - PC - iphone)
or directly (router - iphone hotspot wifi)

If you can have internet on your router in a way or another, connect it and download OpenWrt as explained.

So you can't get internet on the router form iPhone hotspot? if so:

  • Confirm that iPhone hotspot works, Try to get PC to connect to it and see if you have internet access. Some providers block tethering.

  • If you confirm that hospot works with PC, then the next step would be to find what's wrong with configuration.

Go to and Ping and also See if any of them will success..

From ssh, get the output of the following commands. Remember to mask out your MAC addresses and passwords. If you are on Windows, you could use PuTTY for SSH access.

cat /etc/cnofig/network
cat /etc/config/wirless
cat/etc/config firewall
cat /etc/config/dhcp

Thank you!

  1. Confirm that PC has the access and internet from wifi iphone hotspot.
  2. Conrirm that iphone shows router connection to it.

But. Router doesn't use iphone internet.

OK, then it seems that you have something wrong with the config.

To make things confg simpler, delete the master WiFi you created, and try one more time to see if you have internet, then get the config from SSH as explained in my previous post.

You're right.
Now I have the access to the internet. Ping to openwrt and

I can 'update list' in packages. But now this button is gone.
What I can see now.

if I understand the Putty correctly, I connected to my router.
log file with your commands:


BusyBox v1.28.4 () built-in shell (ash)

| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -| || | | || || |
_____|| |
||||___||| |____|
| W I R E L E S S F R E E D O M

OpenWrt 18.06.2, r7676-cddd7b4c77

=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.

root@OpenWrt:~# cat /etc/cnofig/network
cat: can't open '/etc/cnofig/network': No such file or directory
root@OpenWrt:~# cat /etc/config/wirless
cat: can't open '/etc/config/wirless': No such file or directory
root@OpenWrt:~# cat/etc/config firewall
-ash: cat/etc/config: not found
root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/'
option nonwildcard '1'
option localservice '1'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv6 'server'
option ra 'server'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'

So removing the client WiFi solved the router's internet issue?

Not sure why. But you could use SSH

opkg update
opkg install travelmate
opkg install luci-app-travelmate

Just reset the all settings in the router and scan once again.


root@OpenWrt:~# opkg update

Collected errors:

I think now I install Travelmate correctly

Travelmate settings:

Wireless overview:

Good. You can then check the forum Topics to see how to set up Travelmate

Thank you for your patience and help!

By the way, travelmate has a bad documentation for dummies.
If you can help to configure it, it will be great!

You are welcome.

I'm afraid I don't use it myself, so I can't be of much help. Check the forums, there are several posts about it.

1 Like