Linksys WRT3200ACM post-flash help

I'm trying to get a Linksys WRT3200ACM to work with Spectrum's Hitron EN2251 modem. Prior to flashing OpenWRT, the Linksys' signal showed up and I could open the web portal (192.168.1.1). After installing OpenWRT through the web portal, only the power and Internet lights stay lit white but no signal seems to be coming from the router. Help? Did it get bricked it? Its Internet port is connected to the modem and I've tried resetting it.

P.s. Sorry if this was already solved somewhere -- I found some 2020 and older posts mentioning the WRT3200ACM but these weren't helpful. When I search for more I get prompted with "Site is under extreme load, search is disabled, try again later" so my apologies if this is somehow annoying. Any help is much appreciated!

These Routers have two partitions if I remember correctly, so if it was a bad flash it should switch back to the working partition on failure to boot 3 times.
(You can also force this behavior by turning the router off when the power light starts to blink. Do it 3 times then the 4th power on should switch partitions)

Have you tried using a wired connection to see if the router assigns you a LAN IP? usually it's "192.168.1.x"

1 Like

So I tried connecting via LAN and yes, I managed to sign in to the portal but I still don't have an internet connection. So far I've just set the admin and WiFi passwords, set wireless signal name and enabled it, ensured that the country location is set correctly. I can now connect to the router wirelessly but no internet. What's going on?

Is your WAN interface getting assigned the correct IP address? or any IP at all?

Sometimes Modems do not give out IP addresses unless it is to a known MAC address.
Usually you could just unplug the modem from the wall socket for like 1 minute and plug it back in to see if it resets the MAC address cache and lets it try to assign a new IP, of course if that doesn't work you can also clone the old MAC address and assign it to your WAN interface. (On consumer routers they usually have a sticker on them with the old MAC address.)

2 Likes

Alright, sorry for the delay. Finally got my ethernet-equipped machine running again. Turning router and modem off for a few minutes didn't fix it. I see the MAC of the previous router on the sticker but how do I clone it to the new router? I went to Interface, WAN, edit, Advanced Settings, but I don't see any options in any of the WAN edit tabs to change the MAC address.

Network->interfaces->devices->configure
but version dependent

1 Like

Network > Interfaces > Devices tab

Select the WAN device and click on Configure.

On the General Device Options tab, enter the MAC address.

1 Like

@OldNavyGuy @anomeome Thanks guys, this worked!! That minor detail is all it took for me to finally get the router online. The screenshot came in handy, appreciate it. Bought the baby for $100 a week ago off Facebook Marketplace (currently selling for $240 used on Amazon and $140 used on Ebay) and finally got it running. Next up, find a good OpenWRT replacement for my modem (I have about 400Mbs service). This community isn't very well known but seeing how welcoming and helpful you guys are, I really hope it grows a lot soon. God bless you all, until next time. :partying_face::beers:

So I just noticed that now my ethernet has internet access but WiFi connection still doesn't. The MAC addresses showing for my internet addresses are unique. Any ideas on what's going on here?

You might want to take a look at the OpenWrt docs on configuring WiFi...