Linksys WRT3200ACM - no uplink

I acquired a Linksys WRT3200ACM that is used but in fantastic shape for crazy cheap. The previous owners didn't have it long before they switched internet providers and got all new gear. This will be replacing an older device I have that's been giving me fits recently and needs a swift kick and reboot every week or so.

I want my laptop to connect to the wireless, but get DHCP from my server and I want my laptop to appear on the same LAN as the rest of my systems. No biggie. I've done this a few times before with OpenWRT.

I configure the wifi in Network->Wireless to match the previous configuration.
I configured the DHCP/DNS in Network-> DHCP and DNS to match the previous configuration.

I dumped all the WAN connections in Network->Interfaces then configured the LAN with br-lan to have a static IP/gateway/yaddayaddayadda, I disabled the DHCP server, and in the Physical Settings I made sure that all interfaces were bridged.

Everything I can find looks nearly identical to my current setup... But I can only access the device itself. The light flashes that it is connected to the internet uplink port (and on my LAN switch), but the WRT3200ACM never shows up on my LAN and I can't access my LAN from the device.

Is the port bad? Nope. If I reset back to OpenWRT defaults, it will gladly pick up a DHCP IP and let me connect to it via 192.168.1.1... so the hardware works, but when I set it up for it all to be on the same LAN it just won't do anything with that port.

I'm stuck... I've been trudging through various topics and not finding anything that works. Any thoughts on where I'm going wrong? Am I just missing a checkbox somewhere in the interface? Or is this an issue with the WRT3200ACM?
Thanks!

ARP table poisoning / double assigned IP address --> Turn all connected devices off and on. Try all the different LAN ports / new cable.

Thanks for the suggestion. I have tried different cables. I didn't shut off every device, but the IP is a new one from what the old device is so I don't think I've got ARP poisoning....

Good call on plugging in to a different port. If I connect to one of the 4 LAN ports the device shows up AND it's working as expected! That's awesome! Thanks!

I was hoping to use the ports for other things but if I have to give up a few ports... eh... But I still wonder why it won't use the uplink port...

1 Like
root@MyRouter:~# cat /etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdfa:4601:af67::/48'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.50.1'
	option ipaddr '192.168.50.102'
	list dns '192.168.50.10'
	option delegate '0'
	option type 'bridge'
	option ifname 'eth0 eth0.1 eth1'

root@MyRouter:~# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option filterwin2k '0'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option localservice '1'
	list server '/host.my.domain/192.168.50.10'
	option nonwildcard '1'

config dhcp 'lan'
	option interface 'lan'
	option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

root@MyRouter:~# cat /etc/config/firewall
config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option src_ip		fc00::/6
	option dest_ip		fc00::/6
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT

# include a file with users custom iptables rules
config include
	option path /etc/firewall.user

No switch configuration!?