Linksys WRT3200ACM, low wired interface performance after 22.03 upgrade

Hi All,

i have noticed weird behavior of Linksys WRT3200ACM after 22.03 upgrade.

When I have connected devices which are all 1gbit to the router everything seems to be OK.

As soon as i connect at least one device with 100mbit/s interface then traffic to the router from that 1gbit devices is not more that 100mbit/s. Traffic from router to 1gbit device stays 1gbit so it looks like router is reducing transfer only one way.

When i disconnect all 100mbit devices situation goes back to normal, 1gbit devices can achieve transfer around 980mbit/s both ways.

I was testing using iperf3 on 4 devices, all behaves the same.

This is how it looks like from 1gbit device to router:

[  5]   0.00-1.00   sec  11.7 MBytes  97.9 Mbits/sec    0   99.0 KBytes
[  5]   1.00-2.00   sec  11.4 MBytes  95.9 Mbits/sec    0    105 KBytes
[  5]   2.00-3.00   sec  10.9 MBytes  91.7 Mbits/sec    0    105 KBytes
[  5]   3.00-4.00   sec  9.94 MBytes  83.4 Mbits/sec    0    105 KBytes
[  5]   4.00-5.00   sec  10.9 MBytes  91.7 Mbits/sec    0    105 KBytes
[  5]   5.00-6.00   sec  11.4 MBytes  95.4 Mbits/sec    0    141 KBytes
[  5]   6.00-7.00   sec  11.2 MBytes  93.8 Mbits/sec    0    141 KBytes
[  5]   7.00-8.00   sec  11.5 MBytes  96.4 Mbits/sec    0    141 KBytes
[  5]   8.00-9.00   sec  11.2 MBytes  93.8 Mbits/sec    0    141 KBytes
[  5]   9.00-10.00  sec  11.2 MBytes  93.8 Mbits/sec    0    141 KBytes

and here is simply reverse mode test of iperf3 on the same device straight after above test:

[  5]   0.00-1.00   sec   110 MBytes   925 Mbits/sec
[  5]   1.00-2.00   sec   112 MBytes   937 Mbits/sec
[  5]   2.00-3.00   sec   112 MBytes   937 Mbits/sec
[  5]   3.00-4.00   sec   112 MBytes   936 Mbits/sec
[  5]   4.00-5.00   sec   111 MBytes   935 Mbits/sec
[  5]   5.00-6.00   sec   112 MBytes   936 Mbits/sec
[  5]   6.00-7.00   sec   111 MBytes   932 Mbits/sec
[  5]   7.00-8.00   sec   111 MBytes   935 Mbits/sec
[  5]   8.00-9.00   sec   112 MBytes   936 Mbits/sec
[  5]   9.00-10.00  sec   112 MBytes   936 Mbits/sec

Anyone else have the same issue?

How to start even trtroubleshooting something like that?

Thanks for any help.

post

Thanks a lot!

So basically this kind of script:

#!/bin/sh
if [ "${ACTION}" = "ifup" ]; then
if [ "${INTERFACE}" = "lan" ]; then
ethtool -A lan1 autoneg off
ethtool -A lan1 autoneg on
fi
fi

if you put it in /etc/hotplug.d/iface then the problem seems to be resolved. Remember to change lan port number or add another ports if you have more than one device with interface lower than 1gbit.

From my understanding you don't really need to disable auto negotiation, you just have to re-set it.

Correct me if I am wrong.

I'll try it. This seems more correct...