Linksys WRT3200ACM 5GHz Wifi


#1

I just recently had an issue with my 3200ACM router. It had been running on LEDE/OpenWRT pretty much since I got it about a year and a half ago. There were a few issues at first, but as updates came, the problems went away until a couple weeks ago. When I am on OpenWRT, I no longer have access to the 5GHz network. It shows as active and available, but when I try to connect from any device (multiple computers and phones), nothing will connect. In Luci, it shows as "Wireless is not associated". I tried multiple settings as well as auto with no change, and also reset to original OpenWRT settings without success. As a final resort, I switched back to the factory firmware, and low and behold, everything is working again.

I didn't have time to try going back to OpenWRT until today due to the holidays, and the same issue is coming back again on OpenWRT. I was on the latest OpenWRT image and all packages, including the WiFi driver, were up to date. I switched back to the factory firmware again just so I have both networks again, but can go back to OpenWRT for testing to get more information if people can help figure out what is going on. It just seems odd to me that it works fine on the factory firmware, but not OpenWRT, and also that it is only affecting the 5GHz wireless and not both. Any help would be appreciated as my initial checks did not show anything.


#2

Works just fine using master/snaphots?
To be more precise: https://github.com/diizzyy/openwrt/commits/production-20182212 however none of the changes should affect wifi functionality from non working to working.

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '44'
        option hwmode '11a'
        option htmode 'VHT80'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'cookienet-5GHz'
        option encryption 'psk2'
        option key 'cookiemonster'
        option wpa_disable_eapol_key_retries '1'

Wlan0, 5g radio trouble on acm3200
#3

I didn't try a snapshot build initially, but I just flashed one and 5GHz is working on the build I downloaded that was from 1/3/19. Any idea why it would have stopped working out of no-where though? I was not installing any package updates and the router did not restart when the problem came up. The situation in which it stopped working is what confused me, as did the fact that it worked fine on the stock firmware, and now the snapshot build of OpenWRT, but the 18.06.1 build does not work.


#4

Stock firmware uses another driver
You can try modifying your /etc/config/wireless like the above to see if it helps (channel and htmode).
Encryption should be psk2 but ssid and key is up to you of course :slight_smile:


#5

Lastest master/snapshot works fine with me as well.

Try doing the following for your 5GHz:

  1. Set channel to 153, 80 MHz
  2. Make sure your SSID is different than your 2.4GHz one
  3. Use WPA2-PSK with Force CCMP (AES)
  4. Unmask your password and make sure it's set to what you expect

Diizy's settings should work too.


#6

Ok. At the moment I switched back to the Linksys firmware as one of my Wifi devices was not connecting to the 2.4 GHz wireless network, though based on the log, it was authenticating ok, it just wouldn't connect. I'll try to flash the 18.06.1 build again tonight and change the settings for the 5 GHz network. Below are the settings I was using before. I did trying setting a specific channel, though not the exact one you specified above, and 'auto' as well, but nothing I tried worked.

/etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option country 'US'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option legacy_rates '1'
	option htmode 'VHT80'
	option channel '100'
	option txpower '23'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option channel 'auto'
	option htmode 'HT40'
	option country 'US'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option legacy_rates '1'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option network 'lan'
	option hidden '1'
	option encryption 'psk2'
	option wpa_disable_eapol_key_retries '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option hidden '1'

#7

I tested out the 18.06.1 build using channel 44 versus auto and the other static channel numbers I tried initially, and it works. Now the question is, why doesn't it work in auto, or with some of the other channel numbers?


#8

I am not quite sure why auto doesn't work. A year ago or so I found that if I have auto and it roams into the range of DFS channels that I just get dropped and can't connect for a few minutes. That may be fixed in newer versions of the driver, but since setting a channel I haven't had any issues.

Glad that 18.06.1 is working for you. Snapshots also are working, but you need to SSH to install Luci if you go that route.


#9

In this context "auto" means "first channel in the band", there is no advantage over specifiying a channel.