Linksys WRT1900acs v2 does not have valid IP config after LEDE install

I tried flashing my Linksys wrt1900acs v2 with the firmware lede-17.01.4-mvebu-linksys-wrt1900acs-squashfs-factory.img and now i can't connect to it at all. Windows tells me that my network does not have a valid IP configuration. I have tried to ssh into it but that does not work either. The lights on the front of the router still look like it it behaving normally. Have i killed it with the wrong image file?

This is probably related to that commit:

And fixed with this commit:

Use a newer trunk image and issue will be fixed...
Happens only on a clean flash.

Failsave mode should work anyway...

The 17.01.4 series was not affected by these commits.

Ups... Did not get it that he uses 17.04.
Shame on me.

Anyway. Try with fixed ip on your pc (ip netmask and probably with failsave mode.

Thanks for the reply. I have managed to boot it into fail safe mode. I set a fixed IP on the computer and windows is still saying the network does't have a valid IP config. I did notice now when i try to access it doesn't time out, it says it can't connect to the server. So i tried to ssh into it again and it worked. I don't have much experience with linux command line apart from following a few tutorials. Is there a way to flash the stock firmware back on through ssh?

Looking through the file system i opened /etc profile and it is displaying a message saying
'Your JFFS2-partition seems full and overlayfs is mounted read-only.'
'Please try to remove files from /overlay/upper/... and reboot!'
Not sure if i have just opened something that is always there or it is a valid issue.

Thanks for the help, i managed to get it up and running with stock firmware again. After wiping the JFFs2 file system as per the openwrt generic fail safe wiki through ssh i was able to access the web GUI. There was still no valid IP config and i couldn't flash stock firmware from the web GUI, so i had to use WinSCP to copy the firmware file to the /tmp directory and flash the firmware using the sysupgrade command with -n -F flags to force the install. Hopefully this can help someone else if they have a similar issue. Again thanks for the suggestion of the fail safe boot as that is what got me to the answer.

How can you transfer a image with winscp if ip config is not ok?
Probably windows does only comply about no internet connection... Or you have a second active network device with the same subnet running on your pc...

1 Like

Did you follow the Flashing Firmware steps laid out in the WRT AC Series ToH page?

  • Did you flash via WiFi or ethernet?

What was the output from the system log? Issue: logread

  • Simply guessing at this or that is pointless, and the system log output would be required, especially the boot log portion.
    • This can be accessed either via SSH (DropBear / OpenSSH) or Serial
      • If you have not yet invested in a USB-TTL cable or USB-UART, this should be had prior to flashing any 3rd party firmware
        • Serial access is the only way to troubleshoot boot related issues (which it appears this is). This is why it's the second bullet under Introduction
1 Like