Linksys USB3GIG - RTL8153 Chipset - not recognised on OpenWrt for Pi 4

OpenWRT Snapshot Firmware: openwrt-bcm27xx-bcm2711-rpi-4-ext4-factory.img.gz
Running on a Pi 4.

I have a Linksys USB3GIG USB/Ethernet adapter but I can't get it to work in OpenWRT.

I installed this driver...
opkg install kmod-usb-net-rtl8152

But I don't think it is the right one. I get these messages in dmesg...

It looks like the driver is registered and the device appears in ifconfig -a but does not appear in ifconfig

This GitHub page mentions that the Linksys USB3GIGV1 USB 3.0 Ethernet adapter is based on Realtek's RTL8153 and it is only supported officially on Windows and Mac devices.

The GitHub page goes on to propose an improved driver but that requires build-essentials on the host OS so the driver can be built from sources.

Is this what my problem is here and can I build that GitHub driver on my OpenWRT OS? I had a look and don't think I can opkg the build-essentials.
I tried:
opkg list build*
But got nothing back.

Any help very much appreciated,

Flex

I think the issue here might be that OpenWRT doesn't have drivers for the RTL8153 Chipset. Can anyone confirm if this is so and is it possible to add the correct driver for Linksys USB3GIG to OpenWRT for Pi 4, or how would I do that?

I CAN get this Linksys USB3GIG to work fine on Raspberry Pi OS 32-bit:

root@routerpi:/home/pi# uname -a
Linux routerpi 5.4.72-v7l+ #1356 SMP Thu Oct 22 13:57:51 BST 2020 armv7l GNU/Linux

The adapter shows up under ifconfig as eth1 and here is the output of ethtool:

Cheers,

Flex

When ifconfig -a shows it, the port exists in the kernel, but it is down. It needs to be attached to a network in /etc/config/network for the uci system to bring it up. The simplest test would be to add it to the lan bridge and confirm that it works like a second lan port.

1 Like

Looks like that was the issue!

I connected the Pi 4 running OpenWRT to my LAN using the Linksys adapter (eth1) then changed my /etc/config/network to:

config interface 'lan'
option ifname 'eth1'
option proto 'dhcp'

I can then ssh in to that Pi and obviously enough eth1 shows up under ifconfig

I guess I had something wrong in my config files when trying to set up that pi as a router in the LAN. At least I know the adapter works now.

Thank you so much.

Flex

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.