Linksys not connecting

Ok so I have been using my Linksys EA6350v3 since January of this year and have not had any issues at all. All of a sudden, my internet just refused to work on any devices despite being able to “connect.” Here is my configuration, please let me know if I need to include anything:

IPv4 Upstream:
Protocol: DHCP Client
DNS 1:
DNS 2:


Protocol: Static
IPv4 Address:
IPv4 netmask:
IPv4 Gateway:
IPv4 broadcast:
Use custom DNS servers: N/A

WAN eth1:
Protocol: DHCP client

I have tried changing the gateway on the LAN to but it told me that “the gateway address must not be a local IP address.” Please please help me with this configuration, I have absolutely no clue why it stopped working.

You need to specify a gateway on LAN at all. But I do not think that is the issue.

You need to debug into the issue, do not stop on "internet does not work".

On OpenWrt's GUI, go to Network > Diagnostics and try all three utilities. Then from a computer in your network, do a ping to then, and post the results here.

1 Like

Ok!! Sorry for the delay, I wasn’t home.

Network Utility Results:

Ping: “ping: bad address ‘’”

Traceroute: “traceroute: bad address ‘’”

Nslookup: “Server: Address: ** server can’t find NXDOMAIN (has this twice)

Pinging Results:

All 4 requests to timed out.

All 4 requests to timed out.

Your router does not seem to have any internet connectivity at all... How is the WAN port configured? How is it connected?

1 Like

Definitely remove the option gateway from the lan configuration. The gateway will be inherited throughout the OS when the wan receives a DHCP assignment. This can be confirmed by running route to inspect the routing table.

Like @eduperez said you need to check your modem make sure the cable DSL etc link to the service provider is active and the subscription is current.

1 Like

I have the WAN configured as DHCP. I also tried plugging my computer directly into the modem, but all the diagnostics had the exact same effect. I grabbed the ip and DNS servers and used the gateway it used when auto configuring (couldn’t find subnet mask but just used when I had my computer plugged directly in and then switched back to change the WAN settings to a static version of these as well. That had a similar effect.

The lights on the modem are all reading properly. The lights on the router where the Ethernet ports are have been blinking to signify that there is a signal being passed across. I also got into the modem’s panel and everything seemed to be working fine. Called my ISP, no outages in my area and they can see my modem just fine.

Yeah I noticed it was grabbing automatically so I did end up leaving it blank. I called into my ISP and they can see a connection to my modem and it all looks healthy to them. I also have my bill fully paid so also not a concern (but something I did look into).