I was using the 23.05.5 build on my Linksys EA8500 with 2 AP's (802.11ac/n & b/g/n) without any problems.
I decided to clean flash to 24.10.0 using "openwrt-24.10.0-ipq806x-generic-linksys_ea8500-squashfs-factory.bin" with force option on LuCI.
No problems at all, changed password > changed DNS and everything was fine.
I edited both Wireless Network Access Point to my usual configuration, and enabled.
Then on any wireless device they can connect to my Linksys EA8500 but without internet connection.
And on my Ethernet I realized that I can't reach the internet at all.
So I disabled both AP's and enabled the "ac/n" first, no problems.
The moment that I enable the "b/g/n" it drops the internet connection. I tested with ping 1.1.1.1 -t on Windows CMD to confirm it, and when disabled again it resumes like magic.
I copied both Kernel and System logs from LuCI and uploaded to analysis.
So how can I better help you guys to proper diagnose this and fix on future releases?
First try switching ath10k kmod and firmware to flavours without -ct , if that does not help you have already described problem in release notes with C6V2 and have to downgrade to 23.05.5
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdbe:e87a:4c23::/48'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config device
option name 'lan1'
option macaddr 'c0:56:27:06:11:b1'
config device
option name 'lan2'
option macaddr 'c0:56:27:06:11:b1'
config device
option name 'lan3'
option macaddr 'c0:56:27:06:11:b1'
config device
option name 'lan4'
option macaddr 'c0:56:27:06:11:b1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '143.107.11.1'
option netmask '255.255.255.0'
option ip6assign '60'
option delegate '0'
config device
option name 'wan'
option macaddr 'c0:56:27:06:11:b2'
config interface 'wan'
option device 'wan'
option proto 'dhcp'
option hostname '*'
option peerdns '0'
list dns '143.107.11.97'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
cat /etc/config/firewall
root@OpenWrt:~# cat /etc/config/firewall
config defaults
option syn_flood 1
option input REJECT
option output ACCEPT
option forward REJECT
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1
config zone
option name lan
list network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
config zone
option name wan
list network 'wan'
list network 'wan6'
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1
config forwarding
option src lan
option dest wan
# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4
# Allow IPv4 ping
config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT
config rule
option name Allow-IGMP
option src wan
option proto igmp
option family ipv4
option target ACCEPT
# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
option name Allow-DHCPv6
option src wan
option proto udp
option dest_port 546
option family ipv6
option target ACCEPT
config rule
option name Allow-MLD
option src wan
option proto icmp
option src_ip fe80::/10
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family ipv6
option target ACCEPT
# Allow essential incoming IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
list icmp_type router-solicitation
list icmp_type neighbour-solicitation
list icmp_type router-advertisement
list icmp_type neighbour-advertisement
option limit 1000/sec
option family ipv6
option target ACCEPT
# Allow essential forwarded IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Forward
option src wan
option dest *
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
option limit 1000/sec
option family ipv6
option target ACCEPT
config rule
option name Allow-IPSec-ESP
option src wan
option dest lan
option proto esp
option target ACCEPT
config rule
option name Allow-ISAKMP
option src wan
option dest lan
option dest_port 500
option proto udp
option target ACCEPT
### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
# option src lan
# option src_ip 192.168.45.2
# option dest wan
# option proto tcp
# option target REJECT
# block a specific mac on wan
#config rule
# option dest wan
# option src_mac 00:11:22:33:44:66
# option target REJECT
# block incoming ICMP traffic on a zone
#config rule
# option src lan
# option proto ICMP
# option target DROP
# port redirect port coming in on wan to lan
#config redirect
# option src wan
# option src_dport 80
# option dest lan
# option dest_ip 192.168.16.235
# option dest_port 80
# option proto tcp
# port redirect of remapped ssh port (22001) on wan
#config redirect
# option src wan
# option src_dport 22001
# option dest lan
# option dest_port 22
# option proto tcp
### FULL CONFIG SECTIONS
#config rule
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 80
# option dest wan
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp
# option target REJECT
#config redirect
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 1024
# option src_dport 80
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp
It will show board (dont touch) kmod- and 1 or more -firmware-....ct packages.
You have to uninstall -ct variant and install same packages without -ct. Wired best.
Thanks for the reply, but even with the packages without "ct" as seen on the output, and rebooting after installing, the result is the same, if I enable the "b/g/n" AP the WAN drops, and everyone connected can't access internet.
And I believe that you referenced the thread on GitHub #14541 that could be relevant to my situation, and according to this reply the same device of this user is working on firmware (24.10.0 r28427-6df0e3d02a).
What else can I do to help further diagnose from the devs, and fixes?
Yes, it is a real problem and I could duplicate it on my EA8500. I believe the problem is wrong assignment of the MAC address to the wan port. Try to change the wan port's MAC address to be one less than the lan port's MAC address (currently it is one more) and see what happen. The current wan port's MAC collides with the MAC for the 2.4 GHz radio. You can compare the MAC address assignment between 23.05.5 and 24.10.0 and notice the difference.
I had reported the bug. The change was made from 24.10.0-rc7 to the formal release (24.10.0) trying to solve another IPQ806x bug. When I saw the code change, I knew it might create another problem because "lan MAC address + 1" was used for the 2.4 GHz radio (phy0-sp0). And it does.