Linksys EA8300 w/ OpenWrt//LuCi Toast?

About a week ago my Linksys EA8300 randomly had issues with the internet connection. I reset it, and it all went south. I resorted to the ATT modem radio. The SSID has not shown up since, and I've tried getting into LuCi via ethernet to reset the settings, but no luck. I tried the 3x On/Off cycle to get it back to the Linksys firmware, but that did not work either. I'm truly lost, and dad's getting madder by the minute. Any help?

(Moved to Installing and Using OpenWrt - Network and Wireless Configuration)

By the way, wireless is disabled on OpenWrt by default. You'll have to reconfigure it by wired Ethernet. Re-add the same SSID and passphrase. Hope this helps.

What version of OpenWrt was previously installed?

(If you were using a development snapshot build, LuCI would have been deleted when you reset it)

Does your computer get an IP address from the router via ethernet?
Can you ping the router?

Please note that the OP stated the SSID no longer appears after a reset of the router. This sounds like a successful reset to OpenWrt defaults.

But yes, it's definitely good to note to the OP - that upon reset of Snapshot firmware, they will observe the web GUI missing (if installed) too.

Tried to $ ssh root@ on PowerShell over ethernet, and got this message.

I'm confused, are you stating a problem?

If so, the key would change and this is normal; as you reset the router to defaults. A new key is generated on the first boot.

I'm confused as to what should be done after that message

Ummmm....the instructions on the screen to clear the old key should be followed.

Simply delete it? I must be rarted...

Got it going again, very epic! Thanks dude

1 Like

Hol up, I got thru $ opkg update, went on to $ opkg install luci, but it says there's a file clash.

What should be done?

I suspect the version of OpenWrt snapshot on your EA8300 is perhaps far old and won't work with the current packages.

You should upgrade to latest OpenWrt 19.07.1 which has LuCI.

fwiw, as a Windows user, PuTTY (for SSH) and WinSCP are two very useful utilities. PuTTY will pop up a similar message about keys when connecting to openwrt, just answer 'Yes'.

Try this at your own risk:

If router has internet access, login as root via SSH on, then enter the following commands:

cd /tmp


sysupgrade -n /tmp/openwrt-19.07.1-ipq40xx-generic-linksys_ea8300-squashfs-sysupgrade.bin

Otherwise, download the sysupgrade file to your laptop, and use WinSCP to copy the file to the /tmp folder on the EA6350. Then execute the sysupgrade command as show above.

That got it, thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.