Linksys EA8300 USB Drive Auto-mount on reboot

After a power outage or a manual reboot I have to manually replug the usb drive or reboot multiple times afterwards to have it successfully detected.

drive’s format is ext4 but the same happens with all formats.

And sometimes Force reinstalling kmod-fs* packages works.

Lsusb shows the device is there


Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 0781:5581 SanDisk Corp. Ultra
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

block info doesn’t show it


/dev/mtdblock11: UUID="68936568829" VERSION="1" TYPE="ubi"
/dev/mtdblock13: UUID="56738297638" VERSION="1" TYPE="ubi"
/dev/mtdblock15: UUID="689266539" VERSION="1" TYPE="ubi"
/dev/ubiblock0_0: UUID="77835492-c30617bd-68263hsk-hja782628" VERSION="4.0" MOUNT="/rom" TYPE="squashfs"
/dev/ubi0_1: UUID="Jshejd-73738-425b-bf5a-7383he828uhd" VERSION="w4r0" MOUNT="/overlay" TYPE="ubifs"

block detect output

config 'global'
        option  anon_swap       '0'
        option  anon_mount      '0'
        option  auto_swap       '1'
        option  auto_mount      '1'
        option  delay_root      '5'
        option  check_fs        '0'

etc/config/fstab


config global
option anon_swap '0'
option auto_swap '1'
option auto_mount '1'
option delay_root '5'
option check_fs '0'
option anon_mount '1'

config mount
option enabled '1'
option device '/dev/sda2'
option target '/mnt/sda2'
option fstype 'ext4'

Installed packages:


kmod-usb-core - 4.14.195-1
kmod-usb-dwc3 - 4.14.195-1
kmod-usb-dwc3-of-simple - 4.14.195-1
kmod-usb-ehci - 4.14.195-1
kmod-usb-ledtrig-usbport - 4.14.195-1
kmod-usb-storage - 4.14.195-1
kmod-usb-storage-uas - 4.14.195-1
kmod-usb2 - 4.14.195-1
kmod-usb3 - 4.14.195-1

kmod-fs-autofs4 - 4.14.195-1
kmod-fs-configfs - 4.14.195-1
kmod-fs-cramfs - 4.14.195-1
kmod-fs-exportfs - 4.14.195-1
kmod-fs-ext4 - 4.14.195-1
kmod-fs-f2fs - 4.14.195-1
kmod-fs-fscache - 4.14.195-1
kmod-fs-hfsplus - 4.14.195-1
kmod-fs-squashfs - 4.14.195-1
kmod-fs-udf - 4.14.195-1
kmod-fs-vfat - 4.14.195-1
kmod-fs-xfs - 4.14.195-1
kmod-fuse - 4.14.195-1

Did you solved this issue? I have the same problem.

no I did not, but I haven't really tried again with later updates.

Dead thread but I'll post my research here to help anyone who needs it,

root@OpenWrt:~# lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux 5.4.188 xhci-hcd xHCI Host Controller
Bus 004 Device 001: ID 1d6b:0003 Linux 5.4.188 xhci-hcd xHCI Host Controller
Bus 001 Device 002: ID 152d:0580 JMicron USB Mass Storage
Bus 001 Device 001: ID 1d6b:0002 Linux 5.4.188 xhci-hcd xHCI Host Controller
Bus 003 Device 001: ID 1d6b:0002 Linux 5.4.188 xhci-hcd xHCI Host Controller

root@OpenWrt:~# hub-ctrl -v
Hub #0 at 002:001
 INFO: ganged switching.
 WARN: Port indicators are NOT supported.
 Hub Port Status:
Hub #1 at 004:001
 INFO: ganged switching.
 WARN: Port indicators are NOT supported.
 Hub Port Status:

root@OpenWrt:~# hub-ctrl -h 0 -p 0

root@OpenWrt:~# hub-ctrl -h 1 -p 0
failed to control.
: Broken pipe

first off, the EA 8300 seems to have ganged ports which means they cant be power cycled individually. Second, Hub #0 responds to resets but Hub #1 refuses to be controlled. Hopefully someone can make something out of this

The thing also is the stock linksys firmware doesn’t suffer from this.

Interesting,

I’ll look at that as soon as I have a full backup of my image, maybe your on to something. Maybe it has to do with the xhci controller?

Theres also this: https://openwrt.org/docs/guide-user/services/automation/crelay