Linksys EA8300 Slow Wi-Fi

Hi All,

Longtime user of OpenWRT. I bought an Linksys EA8300 and flashed OpenWRT 22.03.2 onto it.
The problem I am seeing straight away is Wi-Fi transfer speeds are slow (testing pulling few GB ISO from an internal server, getting about 1.5 MB/s on 802.11n).
If I hardwire my laptop into the Linksys then I get normal speeds across the LAN connection (~70MB/s).
I have just enabled 1 (radio0) of the 5GHz radios using WPA2, WMM is on by default.
KRACK is disabled, as is client isolation.
Signal strength is at max (I am only a metre away from the AP).

/etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '100'
        option band '5g'
        option htmode 'VHT80'
        option country 'GB'
        option cell_density '2'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'xxxx'
        option encryption 'psk2'
        option key 'xxxx'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/a000000.wifi'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/a800000.wifi'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

I have tested using the factory firmware vs OpenWRT on 2 devices:
Factory:
WiFi4 device: ~13 MB/s
WiFi5 device: ~30 MB/s
OpenWRT:
WiFi4 device: ~1.5 MB/s
WiFi5 device: ~5 MB/s

Let me know if I can provide more info.

Thanks!

set channel hard, and configured country for radio ?

802.11n isn't 5GHz though, but I'l sure you're aware..

Hey, thanks for responding.
By set channel hard, you mean fix it to a channel rather then auto? If so, yes.
Country configured.

Regarding 802.11n, I was not aware no, I was just going by what Windows was telling me to be honest:
image

Setting from OpenWRT side:
image

Thanks.

How are you connecting on channel 36 if radio0 is configured for channel 100 on Openwrt?

Have you tried dropping VHT to 40?

1 Like

Hi.
I own a MR8300 which is almost identical to the EA8300.
If you are using radio0 (qca9888), I would recommend to set channel to auto in order to avoid DFS interference. I had a lot of issues with this.
Also give infos about the wifi on laptop.

Hey, thanks for your reply. I originally edited the post to add my config after I tried changing channels. I don't seem to be able to edit my post now for it to reflect changes.

I tried VHT 40, but no better or worse.

Hey, thanks for your reply. Radio0 is QCA9886, so similar. I tried auto but speeds still the same unfortunately.
Laptop is capable of Wi-Fi 4 using an Intel Centrino Advanved-N 6205.
I have also been testing with my phone which gets slightly higher speeds, but still much less then it should be, Xiaomi Redmi Note 8 Pro, capable of Wi-Fi 5.

Edit, as a side note, with your setup, do you have all 3 radios under the same SSID? Or do you have them seperated? I was looking into steering down the line (assuming I can fix this issue), but not sure if a good idea or not. Thanks.

Did you calibrate DFS in the factory partition? Read here regarding the MR8300 which is basically the same: Advice to buy Netgear or Linksys router - #13 by KOA

I was note sure about this. Mine is also QCA9886.

No, each radios have a different purpose, and so its own SSID.

You will have no more than 300mbit/s with such laptop. You may need to tweak its properties to accep this, I don't know its default setup.

fwiw, I have EA6350v3 which uses IPQ4018. (EA8300 uses IPQ4019 with extra QCA9886 radio).

I used to own windows 10 laptops with Intel 6200, 6205, 6300 (3x3) wireless N chipsets.

I don't recall seeing 10x drop in speeds based on figures you provided in OP with those laptops. I used channel 48 with 40 MHz bandwidth setting in OpenWrt wifi at the time.

I use OpenWrt 19.07. I have not tested the later versions due to various issues after 19.07.

I still own one EA6350v3 operating as an openvpn client running 19.07.10. I just turned off the VPN and ran a speed test connecting to its 5 GHz wifi from my windows 10 laptop with Intel 7265 AC (2x2) wifi adapter.

My internet service provides upto 75 Mbps.
Here is speed test (routed).
Using channel 36. Using 40 MHz bandwidth setting in OpenWrt to mimic wireless N:
0ea6350
Windows 10 wireless properties reports wireless link of 180 Mbps (EA6350v3 is in poor location)

When I used EA6350v3 with OpenWrt 19 briefly as a dumb access point, I vaguely recall the iperf3 speeds from PC on ethernet to laptop on 5 GHz wireless was able to achieve 200+ Mbps but don't quote me. I recall it was slower than stock firmware. I witnessed compatibility problems with some legacy 2.4 GHz devices so reverted to OEM stock firmware.

Update: I now recall there was a speed issue with windows driver for Intel 6300 when using 5 GHz wifi on EA6350v3, but I can't remember if that was with OpenWrt or stock FW (I think it was with stock FW). I had to downgrade the card in laptop to a spare 6200 to resolve the issue. I don't recall the 6205 being affected.

Hey, thanks for your reply.
I Googled Linksys DFS, and the settings page for my EA8600 doesnt mention DFS in the factory firmware (latest version).
I've tried it anyway, I booted into the other factory firmware, left it for a few hours, then booted back into OpenWRT.
Initally speeds were good, but I've just tested after a few hours on OpenWRT and its back to poor sppeds again. :frowning:

@badulesia
Thanks for the info.
300mbit's... I would be happy if I even got 50% of that speed, currently only getting about 5% of 300mbit's. :frowning:

@Bill
Hey, thanks for your reply.
Possibly my laptop isnt the best, however I am having very similar speed problems with my phone as well.

Have you considered OpenWrt 19.07.10 to see if there any improvement?

(Return to boot factory Linksys firmware and install 19.07 squashfs-factory image)

Tried as per your suggestion to use 19.07.10. The first 5GHz radio I connected to had bad speeds again. The other was acceptable.
Waited 10 minutes and they were both bad.
Waited another 10 minutes and the first radio starting being good, then dropped off again.

Centrino Ultimate-N 6300 here, it's a really awful wireless card, just like yours.

I agree it is limited, but seeing speed issues regardless of what test device I use.

As a general update to my post:
I have noticed that speeds appear to be good in OpenWRT as long as I use a 5GHZ channel that is NOT a DFS channel (even using auto is a problem, depending on what channel it picks to use).
For the first 5GHZ radio this is channel 36-48. However for the second 5GHZ channel there are no channels I can use as 100-140 is DFS and 144-165 is not visible to any of my devices (this could be either due to my devices not supporting these frequencies, or because in the factory firmware support stops at 140 anyway).

This effectively means I can only use 1 of the 5GHZ radios, which is a bit of a bummer. :frowning:

Sorry off topic / not directly related to 802.11n but make sure software offloading is enabled in the firewall.

Also turn on unused cores under: network->interface->global network options

v21 and 22 slowed things down a little this helps give it a boost.

Hi.
On a MR8300 (almost identical to a EA8300), these channels are working. So it may be related to your devices as you suggested. I have an old smartphone that doesn't implement this for example.

You may try to manually select a channel, and wait for a radar detection in the log. That may be a long process, but you should be able to find what is the radar frequencies coverage in your area. Maybe you can find a tool for this.

Hey, thanks for the tip, I have turned this on now. It does mention "May help or hinder network speed though"???

Yeah I think my phone just cant see these channels at all. Thanks.

1 Like