Linksys EA8300 refuses to upgrade

Hi all,

I'm a fairly inexperienced OpenWRT user, so this might be a complete n00b question, if so, I apologise in advance.

I'm currently running two Linksys EA8300 routers with OpenWRT 19.07.4 and 19.07.5. They are connected through a mesh with wpad-mesh. Recently I have been experiencing some devices connected to one of the routers to, without losing WiFi connecting, lose connection to the internet. The only, temporary, solution is to reconnect to the WiFi.

Today I figured it made sense to upgrade the instances of OpenWRT to the latest version. But, no matter what I try, upgrades just keep failing without any message.

It doesn't matter if I use LuCi or the CLI, every time the upgrade starts, but once the device boots up again, it returns to version 19.07.

I've tried various versions (21 and 22) and with or without preservation of settings, the result is always the same.

Any thoughts on what is going on here or how to debug?

tried going to 19.07.10 1st ?
did you use the reset settings while upgrading option ?

Thanks for the suggestions frollic.

With reset settings while upgrading do you mean unchecking the Keep settings and retain the current configuration option? If so, yes, I did. No effect.

I just tested upgrading to 19.07.10, but the same thing happens, I'm still at 19.07.5.

You can always do the TFTP install (same link), but check if the U-boot (bootloader) warning in applies to you.

I have experience with the MR8300 which is almost identical. I suggest you flash a factory image, not a sysupgrade. you can use directly the 22.03.5 file. You won't be able to preserve any settings in the process: settings are kept only since 22.03.3. This means you will need to completely reconfigure.

If you have kept the Linksys fw on the other partition, than switch to it, and flash OpenWrt from it.

Thanks frollic and badulesia, I think the bootloader warning does apply to me. Will try to install a 22.03 from scratch.

1 Like

On another topic, what is your experience of this device using mesh? I tried a year ago. Devices link but the bandwith is very sluggish, and to be true quite unsable. I replace the config with WDS link.

Ok, managed to install a completely clean 22.03. Will try to reinstantiate the mesh later. Thanks for all the input. Was expecting a slightly easier upgrade, but at least I'm on a newer version now.

As for your question, badulesia, I'm quite happy with the mesh. Initially I've set it up just to improve coverage in my (concrete heavy) home and allow the kids to enjoy some wifi on the top floor. My workspace is next to the mesh-connected router where the original wifi signal is still quite decent, but I noticed connecting my work laptop to that router (instead of the internet-connected one) increased the wireless stability and speed by a lot. I'm considering adding one or two of the same routers to improve coverage in my home even more.

Now you can easily perform an upgrade, it works since 22.03.3. You can even keep the settings. Be aware that if you perform an upgrade, it will flash the other partition, not the active one. I don't know if you want to keep a partition with the Linksys firmware.

Well you may have found some "magic" settings that I didn't :slight_smile: At least I know that it's possible.
Would you mind sharing your wireless config once setup in mesh again ?