Linksys EA8300 - keeps crashing on "larger download"


This weekend, I have freshly installed OpenWRT 19.07.3 on my new EA8300 router, hoping this one would allow me to use the full 1 GB fiber connection, which my TP-Link Archer C7 was unable to provide (max about 600-650 Mb/s). A speed test connected directly to the Linksys showed about 900 Mb/s so, I was happy about that.

This morning, I was informed by VMWare Fusion that there is an update, so I clicked the install button and after a few seconds, the download stopped... A disappointed son told me that the TV stopped working and my wife told me she no longer had wifi... Hmmm, oh and the router no longer pings. :frowning:

I rebooted the router and a few minutes later, again, while trying to update VMWare Fusion it crashed again... and another try... again. So, my TP-Link is back in place for now.

Has anyone else experienced these issues with the Linksys EA8300? And any suggestions for a solution?

I'm thinking of adding swap space. Could that help?



Most likely not, I guess you could try a snapshot but be aware of soft-bricking etc and dont save config between updates.

Are you making that big download through wifi or ethernet?

1 Like

Over ethernet, via another router elsewhere in the house.

Laptop --> [TP-Link router] --> [Linksys Router] --> internet

  • Menno

Thanks, right... I have some "not so great" experience with snapshots (hard-bricked a router once). So, before I do that, I'll try adding virtual memory, which should be easy.

  • Menno

fwiw, are you using IPv6 on WAN? If yes, there is a known issue with ethernet controller failing on IPQ40 devices. The workaround was to disable IPv6 on WAN.

I believe it was recently fixed in daily snapshots.;a=commitdiff;h=678569505623e50bbbbc344c7e820fb315b79ede

1 Like

My provider does not do IPv6, yet (not getting any address), but I'm using a 6to4 tunnel to HEnet. I may have to explicitly disable IPv6 on the WAN port, though.

Thanks for the suggestion.

  • Menno

Experiment upgrading to the most recent development version of openwrt:

1 Like

Thanks. I read that the plan for 19.07.4 is mid-August, so if that is the case, I can wait a few days and install the stable version. I can live with "only" 650 Mb/s on my old router for a few days more :wink: If it takes (a lot) longer, I'll try the snapshot.

Once the EA8300 is stable enough, I can move the TP-Link Archer C7 to the attic and finally have good WiFi there, too.

Did the crashes stop in 19.07.4, or did you try the snapshot?
I think I have similar issues in 19.07.3.

I used 19.07.4 and it stopped the crash, but it was unusable for me, due to a (rather fatal) change in how VLANs are used... I was no longer able to map the VLANs in the right way, so waiting for 20.xx.0...

  • Menno

I found that 19.07.4 works fine, and you can get vlan to work just as it did in 19.07.3, as long as you do your own build and remove target/linux/ipq40xx/patches-4.14/716-essedma-vlan-double-tag.patch

I've seen that, but I first need to figure out how to set up my build system (I used to build my own Linux kernels in the old days, but that's a long time ago... In the 0.x and 1.x days...). There are only so many hours in a day :frowning:

So, actually, I was still getting crashes in v19.07.4 (and even master/snapshot). The crash was taking place at various points in the rx skb handling in drivers/net/ethernet/qualcomm/essedma/edma.c. And I was not understanding what could possibly be going wrong. The packets coming in were just suddenly corrupted, and sometimes it even persisted after the triggered soft-reset, which would then cause a permanent lock-up (until a hard power-cycle).

But (after a day of debugging and too much coffee / maybe a beer) I finally messed with cpu frequency scaling, and the crashes are gone! Just put this in your /etc/rc.local:

echo 716000 > /sys/devices/system/cpu/cpufreq/policy0/scaling_max_freq
echo 716000 > /sys/devices/system/cpu/cpufreq/policy0/scaling_min_freq

You mileage my vary, but it did it for me. I read somewhere that Linksys pegs the cpu to max frequency in their stock firmware for this model.
Setting the frequency to a fixed 500000 (500 MHz) instead of 716 MHz also prevented the crashes, but had slightly slower performance. Other than the small contribution to Climate Change, I see no real risk to pegging to 716 MHz, as long as Linksys thinks it's OK, which apparently they do.


Much appreciated tip, however I noticed my EA/MRs ran noticeably cooler with OpenWrt, I guess now explained by variable CPU frequency. Just be aware that your unit likely runs warmer and depending on environment temp, a lot warmer.

1 Like