Linksys EA7500 V1 GUI flash fails

Hello, I'm trying to flash my EA7500 V1 to openwrt.

Steps are to first flash to the older Linksys image FW_EA7500_1.1.2.172843_prod.gpg.img more than twice to make sure both A and B images are overwritten which I have done but I still get "Invalid firmware file" errors trying to flash with openwrt-21.02.1-ipq806x-generic-linksys_ea7500-v1-squashfs-factory.bin. I noticed I also can't flash to the Linksys firmware FW_EA7500_1.1.2.172843_prod.img download file either, same error, only the gpg version flashes.

Just checking if there is anything else I should be trying before I go the serial port route (waiting on amazon shipment). Is there an even earlier version of Linksys software to try?

I am flashing by logging into the router and going to the Connectivity page then under Router Firmware Update clicking the "manual" button.

I'm doing this on a macbook pro m1 if that makes any difference.

Thanks!

I did this last week
I'm in Australia but i use the US firmware as stated & linked

did that 2x & then openwrt & sysupgrade for the 2nd openwrt
all worked as stated
the only pain was the linksys side downgrading

Yes that's the directions I am trying to follow. I even tested "reverting" the firmware to make sure it was only 1.1.2 on the router. I am really hoping that I am doing something wrong instead of it being a stubborn router.

somthing I do automaticly these days
is to use the borwser in private mode (firefox)
when 1st loggin into or flashing
something for you to try

I tried your idea with firefox no go so its serial time. trying the 1.8v method it says no desoldering but qa5 and qa6 are removed in the picture? do they need to be removed or not?

I have never had to open one so i don't know
my 2xea8500's & my ea7500 all just worked
but i have just come to know the EAA8500 if in the US has to be done via serial
so maybe this is the same

There is a second page to the linksys checksums which list 1.1.2.170091 firmware

I'm going to try that.

No luck =(

learned the gpg firmware is encrypted and the router won't take firmware that is not signed with linksys key.

Guess I'm going to try serial now. Did you have any luck? Do I have to unsolder things if my serial conector can change voltage/ I don't hook up the voltage pin?

yes, correct.