Linksys EA7500 v1 and OpenWrt?

I build every couple days (usually with a new kernel version). I keep a backup repository of prior builds - beta software will have hiccups when trying to support such a broad base of devices. Gotta be ready to revert back :sunglasses:

Same issue, any workaround suggestion? :joy:

Now, the website is giving 502 errors...

image

With snapshot r14935-95b0751d0f. the wifi throughput is weird. I'm using an Intel Ac-8265 card, at less than 2 meters from the router, using the 5 GHz band, on AC mode and 80 MHz of bandwidth, on an empty non-DFS channel.

With iperf3, through the WAN, with Firewall on, and parallel streams:

4
[SUM] 0.00-180.01 sec 4.22 GBytes 202 Mbits/sec receiver

8
[SUM] 0.00-180.00 sec 4.03 GBytes 193 Mbits/sec receiver

16
[SUM] 0.00-180.01 sec 4.17 GBytes 199 Mbits/sec receiver

32
[SUM] 0.00-180.01 sec 4.91 GBytes 234 Mbits/sec receiver

64
[SUM] 0.00-180.01 sec 6.39 GBytes 305 Mbits/sec receiver

Why is this getting more 50% speed with almost 64 streams?

And the speed test (fiber 500/100) is awkward:

Found the issue regarding the odd radio TX rates and bandwidth, on ath10k:

@M10

How did you get a terminal up? I'm game to test images.

While much of this is new to me, I seem to be using all the suggested settings.
20201120_111931
Soldered on TX, RX, GND as pictured in device data
Plugged in Si CP2102, set to 1v8
Installed drivers and noted com port
Set putty to 115200 8n1 no parity & no flow control

When the USB bridge is powered and plugged in, the router hangs on boot, but when disconnected the ea7500 will boot fine. Regardless of timing of connection, I get no data in terminal.

Any guidance available?

Hi,
I am getting EA7500V1 at a bargain. I want to run openwrt on it. Is it fully supported? By that I mean stable wifi (both 5ghz and 2.4ghz) speed and uptime?

Thanks in advance.

Well, despite header voltages looking right and soldering like the example picture, I seem to have cooked my board after a few boots/attempts to get terminal up. The board now only seems to power properly when the ttl leads are connected, but I still don't get a terminal.

do You have 1.8v and 3.3v from board?

@M10
I do get 3.3, but I do not get 1.8 at the tx rx headers. I got a ttl adapter that supported 1.8, but seem to have lost voltage regulation on 1.8 and now rx/tx swing from 1.7-2.5. An led on the back of the board at power cycle button blinks quickly. When the usb adapter is attached it calms down and would seem to boot. Stabilizes the voltage maybe? I haven't tried much after seemingly cooking it.

it looks like You fried 1.8v regulator , any not normal looking components near serial header ?

No, I cant tell what let the smoke out. I couldn't get a serial connection up anyway.

Guide: Easy way to get serial access without soldering

So, the device wiki page is very confusing and misleading. I was able to flash the openwrt factory firmware pretty easily without "unsoldering" or soldering anything on the board.

My EA7500 has the pin headers already there and I used a master communications ftdi board with the 3.3v jumper set, and just connected TX, RX, and GND.

I flashed the recommended downgrade twice, and also made sure my tftp server was up and running with the right ip.

Once that was done I pulled up "picocom" in linux with the correct serial settings, 115200 8N1, and turned the router on. Instantly I got to see the entire boot up process of the Linksys firmware. I shut it down, turned it on again and this time hit a key to interrupt u-boot, and followed the rest of the instructions in the wiki.

No problem!

But, I do have a question, maybe even an issue.

I am showing only 3.6mb available for opkg software. That is not gonna work for me. I grabbed this router cause it is supposed to have 128mb NAND which from my experience with the AR300M gives plenty of space for me to work with. Whats going on here? Is it the double firmware thing that Linksys has on this router? Couldn't the partition table be changed to something more pratical?

Did I do something wrong?

Thank you to the development team, I really feel like openwrt is a superior operating system for my networking needs.

Jimmy

root@OpenWrt:/# block info
[ 1380.507651] blk_update_request: I/O error, dev mtdblock0, sector 0 op 0x0:(READ) flags 0x80700 phys_seg 4 prio class 0
[ 1380.515386] blk_update_request: I/O error, dev mtdblock0, sector 8 op 0x0:(READ) flags 0x80700 phys_seg 3 prio class 0
[ 1380.518868] blk_update_request: I/O error, dev mtdblock0, sector 16 op 0x0:(READ) flags 0x80700 phys_seg 2 prio class 0
[ 1380.529926] blk_update_request: I/O error, dev mtdblock0, sector 24 op 0x0:(READ) flags 0x80700 phys_seg 1 prio class 0
[ 1380.540289] blk_update_request: I/O error, dev mtdblock0, sector 0 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[ 1380.549478] Buffer I/O error on dev mtdblock0, logical block 0, async page read
[ 1380.564189] blk_update_request: I/O error, dev mtdblock0, sector 32 op 0x0:(READ) flags 0x80700 phys_seg 7 prio class 0
[ 1380.584298] blk_update_request: I/O error, dev mtdblock0, sector 40 op 0x0:(READ) flags 0x80700 phys_seg 6 prio class 0
[ 1380.624284] blk_update_request: I/O error, dev mtdblock0, sector 48 op 0x0:(READ) flags 0x80700 phys_seg 5 prio class 0
[ 1380.653992] blk_update_request: I/O error, dev mtdblock0, sector 56 op 0x0:(READ) flags 0x80700 phys_seg 4 prio class 0
[ 1380.694277] blk_update_request: I/O error, dev mtdblock0, sector 64 op 0x0:(READ) flags 0x80700 phys_seg 3 prio class 0
[ 1380.767491] Buffer I/O error on dev mtdblock0, logical block 1, async page read
[ 1380.773766] Buffer I/O error on dev mtdblock1, logical block 0, async page read
[ 1380.782478] Buffer I/O error on dev mtdblock1, logical block 1, async page read
[ 1381.085998] Buffer I/O error on dev mtdblock2, logical block 0, async page read
[ 1381.096599] Buffer I/O error on dev mtdblock2, logical block 1, async page read
[ 1381.102423] Buffer I/O error on dev mtdblock3, logical block 0, async page read
[ 1381.105956] Buffer I/O error on dev mtdblock3, logical block 0, async page read
[ 1381.115664] Buffer I/O error on dev mtdblock4, logical block 0, async page read
[ 1381.128795] Buffer I/O error on dev mtdblock4, logical block 0, async page read
/dev/mtdblock14: UUID="1612296405" VERSION="1" TYPE="ubi"
/dev/mtdblock16: UUID="1333238185" VERSION="1" TYPE="ubi"
/dev/mtdblock18: UUID="459140831" VERSION="1" TYPE="ubi"
/dev/ubiblock0_0: UUID="a07e7566-89ce4cb2-2233b800-8311c335" VERSION="4.0" MOUNT="/rom" TYPE="squashfs"
/dev/ubi0_1: UUID="eb784e36-7b13-46a7-9d62-77f8ddaeed6d" VERSION="w5r0" MOUNT="/overlay" TYPE="ubifs"

For those who might want to test and use the Kong builds on this router, they are available right now, here.

The biggest improvement from the main builds is the NSS cores enabled for more performance in encryption and heavy network operations, such as SQM.

Huge kudos for @KONG!

Thanks for sharing!

I was not aware that @Kong also has a nss build for the ipq8065/8064, which seems different than the community nss build for the ipq8066/8064 from @ACwifidude. Does anybody know what is the difference between the nss portion of the two builds i.e. what works better in one than the other, etc?

Also, I see that source code of @ACwifidude is available to compile the build, but could not find the same for @Kong nss builds. How does one compile the nss build from @KONG from source? Thanks.

No they are the same source I use ACwifidudes source, just different package selection. Just fixed the dts for the ea units as ACwifidudes last changes broke EA builds.

1 Like

Got it. Many thanks for the prompt response. Appreciate it!

So does that mean that I just need to copy the qcom-ipq8064-ea8500.dts file from https://www.desipro.de/openwrt/sources/ to the dts folder for @ACwifidude sources, and I should be ready to do nss build for the EA8500, while for the other routers (EA7500v1, R7500v2, C2600) I don't need any other sources from desipro.de for nss build?

BTW, I see there are a handful of other source files in https://www.desipro.de/openwrt/sources. Could you share what they do and when they should be used, for builds? Thanks!

Ah, those files are all outdated. Just use acwifidude code and make the change from:

that's it.