Ipq806x NSS build (Netgear R7800 / TP-Link C2600 / Linksys EA8500)

When you use the December 31st build .dts and .dtsi gmac settings do you get reboot issues?

no reboot,it's ok
but get crash after couple days sometime

Seems like the December settings are better than the current ones. Sounds like I should load the December settings.

I have added the packages with make menuconfig after make defconfig, other packages are included in the build but not this one.


and the December 31 for ea8500 is amazing for the moment,no rebooting over 7 days at least
and whatever do usb print job or Mount Points samba sharring ,no dead or freeze ,not like ea7500

This fixes nss gmac crash on the ea8500:

diff --git a/target/linux/ipq806x/files/arch/arm/boot/dts/qcom-ipq8064-eax500.dtsi b/target/linux/ipq806x/files/arch/arm/boot/dts/qcom-ipq8064-eax500.dtsi
index 30300681de..f24344c379 100644
--- a/target/linux/ipq806x/files/arch/arm/boot/dts/qcom-ipq8064-eax500.dtsi
+++ b/target/linux/ipq806x/files/arch/arm/boot/dts/qcom-ipq8064-eax500.dtsi
@@ -184,9 +184,9 @@
        phy-mode = "rgmii";
        qcom,id = <1>;
        qcom,pcs-chanid = <0>;
-       qcom,phy-mdio-addr = <4>;
-       qcom,poll-required = <1>;
-       qcom,rgmii-delay = <0>;
+       qcom,phy-mdio-addr = <0>;
+       qcom,poll-required = <0>;
+       qcom,rgmii-delay = <1>;
        qcom,phy_mii_type = <0>;
        qcom,emulation = <0>;
        qcom,forced-speed = <1000>;
@@ -212,7 +212,7 @@
        phy-mode = "sgmii";
        qcom,id = <2>;
        qcom,pcs-chanid = <1>;
-       qcom,phy-mdio-addr = <0>;
+       qcom,phy-mdio-addr = <4>;
        qcom,poll-required = <0>;       /* no polling */
        qcom,rgmii-delay = <0>;
        qcom,phy_mii_type = <1>;

I already uploaded working builds on my site.


Random question.
Does anyone tried performance gov with nss scaling enabled ? Does it still crash?

I have not tried performance governor, but did want to comment that since some release from February 20210207, I think, I no longer get the random reboots. I have used 20210227 and the current that I am using is from 20210315 and it seems really stable on my R7800. Right now, I am running OpenWrt SNAPSHOT r16216+20-c17b1dca60 and it was up for days until ComEd shut down power last week and it has been up another week since then. I have had it go well over 2 weeks w/o reboot and no problems.

The only problem I have has nothing to do with the nss fork, it is that the main repo for LuCI (Master git-21.060.51374-cd06e70 that I'm using) still has the broken interface to the Firewall so that you cannot turn on and off time restricted rules in the UI. You have to do it via cli. This is a pain, but not insurmountable. Just a gripe.

Thanks for all the hard work. It is great!

@Ansuel is that like echo performance > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor; echo performance > /sys/devices/system/cpu/cpufreq/policy1/scaling_governor ?

Yes but the firmware must be changed to enable nss Freq scaling. (Currently is set to the max Freq on every level)

I’ve only built it at the max frequency (except for the couple of builds that I fixed it at 600mhz).

With it fixed at 600mhz the R7800 had a dip below full line rate (upper 800’s with NAT).

Did you ever tried performance governor and normal nss? (nss scaling enabled) (cpu set to the max freq and nss scaling enabled with the 3 freq set in the dts as it should)

I haven’t tried that before. I was following the NSS thread all last year and jumped on board after the big stability improvement with fixing the NSS frequency at max frequency.

My three r7800’s are stable (no reboot issues) with performance governor + max NSS freqency.

Mhhh I would ask some test with performance and nss scaling just to confirm a theory. Don't know if you can test this.

I do add these stuf on my ea8500 .and it's working fine (over 15 days ,no reboot ,no freeze)

did you compile the image yourself?

yes,what can I help you?

patch 999-00-Add.....
you need to change

+			qcom,low-frequency = <733000000>; /* orig value 110000000 */
+			qcom,mid-frequency = <733000000>; /* orig value 550000000 */
+			qcom,max-frequency = <733000000>;


+			qcom,low-frequency = <110000000>;
+			qcom,mid-frequency = <550000000>;
+			qcom,max-frequency = <733000000>;

Tell me if any reboot occurs.
Remember you need this

echo performance > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor; echo performance > /sys/devices/system/cpu/cpufreq/policy1/scaling_governor

This is to test if the reboot are caused by the cpu scaling or the nss scaling. (since it looks like we always tested cpu + nss scaling but never nss scaling and cpu set to max)

ok,got it
I will let you know asap

1 Like
-		sdcc1bam:dma@12402000 {
+		nss0: nss@40000000 {
+			compatible = "qcom,nss";
+			qcom,low-frequency = <733000000>; /* orig value 110000000 */
+			qcom,mid-frequency = <733000000>; /* orig value 550000000 */
+			qcom,max-frequency = <733000000>;

+		nss1: nss@40800000 {
+			compatible = "qcom,nss";
+			qcom,low-frequency = <733000000>; /* orig value 110000000 */
+			qcom,mid-frequency = <733000000>; /* orig value 550000000 */
+			qcom,max-frequency = <733000000>;

Shoud I change both place? this is from @ACwifidude 's lastest master repo