LINKSYS EA3500 - SLOW WIRELESS(2.4Ghz) AND POOR LATENCY


#1

Happy new year to all. I bought a Linysys EA3500 a few days ago and have been battling with it and OpenWRT since then. I have tried LEDE v17, OpenWrt v18.06, OpenWrt v18.06.1 and the latest Snapshot of Jan 2, 2019, all with basically the same results on the 2.4GHz wireless. Throughput(speed) and latency are poor and varies continuously. Is anyone else experiencing these issues? Can anything be done to improve the performance of OpenWrt on this router? Is there anyway I can report this directly to whoever maintains the wireless driver for this router?

Below are some speed results measured with Iperf3 between the router and a PC directly on the 2.4GHz wireless LAN. As you can see the max speed obtained is about 11Mbps(well below my home Internet speed of 35Mbps). Your assistance is appreciated.

>iperf3 -c 192.168.31.1 -p 5201
Connecting to host 192.168.31.1, port 5201
[  4] local 192.168.31.240 port 60548 connected to 192.168.31.1 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  1.05 MBytes  8.77 Mbits/sec
[  4]   1.00-2.00   sec   819 KBytes  6.71 Mbits/sec
[  4]   2.00-3.00   sec   378 KBytes  3.10 Mbits/sec
[  4]   3.00-4.00   sec  1.11 MBytes  9.29 Mbits/sec
[  4]   4.00-5.00   sec  1.29 MBytes  10.8 Mbits/sec
[  4]   5.00-6.00   sec  1.23 MBytes  10.3 Mbits/sec
[  4]   6.00-7.00   sec   378 KBytes  3.10 Mbits/sec
[  4]   7.00-8.00   sec   378 KBytes  3.09 Mbits/sec
[  4]   8.00-9.00   sec   252 KBytes  2.07 Mbits/sec
[  4]   9.00-10.00  sec   693 KBytes  5.68 Mbits/sec

Below are some latency results of ping a machine directly on my LAN:

Pinging 192.168.31.1 with 32 bytes of data:
Reply from 192.168.31.1: bytes=32 time=1ms TTL=64
Reply from 192.168.31.1: bytes=32 time=2ms TTL=64
Reply from 192.168.31.1: bytes=32 time=1ms TTL=64
Reply from 192.168.31.1: bytes=32 time=21ms TTL=64
Reply from 192.168.31.1: bytes=32 time=1ms TTL=64
Reply from 192.168.31.1: bytes=32 time=1ms TTL=64
Reply from 192.168.31.1: bytes=32 time=39ms TTL=64
Reply from 192.168.31.1: bytes=32 time=1ms TTL=64
Reply from 192.168.31.1: bytes=32 time=11ms TTL=64
Reply from 192.168.31.1: bytes=32 time=1ms TTL=64
Reply from 192.168.31.1: bytes=32 time=3ms TTL=64
Reply from 192.168.31.1: bytes=32 time=52ms TTL=64
Reply from 192.168.31.1: bytes=32 time=2ms TTL=64

#2

Too early for a bump? Any assistance? Am I the only one experiencing this issue? Thanks in advance.


#3

Since your ip appears to be 192.168.31.1 I'm curious if you're using it as a repeater? If so and your isp speed is 35mbps, then 11mbps is about right since repeaters halve speed (which you probably already knew, but just in case). Having said that, I used to have an ea3500 and I had problems too and never found a reliable fix, from what I remember the wifi driver hasn't been maintained for quite a while.


#4

It's being used as an AP, not repeater.


#5

Router to PC, maximum LAN speed is:

2.4Ghz - 22Mbps(very poor)
5.0Ghz - 58Mbps(very poor)
Wired - 436 Mbps(half of what it should be)

Measured with IPerf3 on OpenWrt 18.06.0 r7188


#6

Run a iperf test through the router not on the router. When either the iperf server or client runs on the router, the entire test becomes cpu bound and any throughput measures will be skewed and do not reprent the achivable routing speed.


#7

Tried what you said. Wireless(laptop) -> router -> Wired(PC - Gigabit connection) Here are the results:

2.4 Ghz - 14.1Mbps
5.0Ghz - 77 Mbps

Slight improvement on the 5GHz network and poorer results on the 2.4Ghz. My main issue is on the 2.4G. Can anything be done to improve this result? I need 35Mbps or more.


#8

I really love the features of OpenWrt. I plan to use features such as encrypted DNS, virtual private ethernet(Zerotier), TOR and maybe some file sharing. But my experience with throughput and latency on Wifi on all the devices I have tried so far has been poor.

I first tried a Xiaomi R3G router. Worked well with a firmware called Padavan and PandoraBox(Chinese version of OpenWrt but with proprietary drivers). Couldn't trust the Chinese firmware and decided to look to OpenWrt. Unfortunately the router bricked the same day I got OpenWrt installed on it. Tried recovering it with a serial cable but have not been able due to a locked U-boot loader which will not accept serial commands.

Then I tried a Raspberry Pi 3 B. Was able to install OpenWrt but throughput on the wireless is low, like 10 Mbps.

Then I bought a Linksys 3500 , thinking the throughput would be better. Alas, this is not the case as is seen in my previous post on this thread.

I'm really trying to exhaust all options before I spend money on a fourth device. So far, the Archer C7 seems to be the most recommended budget type router for OpenWrt on most forums. If nothing else works, will have to try it out. Hope I am not disappointed if I do.


#9

I had slightly better 2.4ghz speeds on my ea3500 from what I remember, usually in the 30-35mbps range, but 80mbps was the norm on 5ghz, so you're about where I was, I just relegated mine to a repeater and eventually passed it on to a relative.


#10

Would you mind sharing your current OpenWrt device of choice?


#11

Sure, i have a Linksys wrt1200 v1, got it on sale a couple of years ago for $129, but you might be able to find them around $80 these days, although even that's twice what paid for my ea3500, so the 1200 isn't really a budget router, but it's rock solid on Openwrt, i get my full 200 down 10 up consistently with no problems. But one of the wrt1900 models might be a better choice now if you go in that direction since you can probably find them in the same price range these days.


#12

I'm sorry you aren't having good luck. What does the spectrum look like where you live? Are you in a dense area with overlapping 2.4Ghz APs? I think I'd attack that first before throwing more hardware at the problem. It is an old box though with a fairly slow SoC.


#13

I've been testing an EA3500 with OpenWRT/LEDE for about a week now and have noticed a few issues that are worth mentioning as of this date (2/1/18).

v18.06.2 cannot be succsefully flashed to the device. It will fail on boot and revert to the previously flashed firmware/settings.

v18.06.1 can be flashed, but there are sporadic latency issues on all connections, and another bug that affects speed on all LAN interfaces, so it's probably a WAN issue (I've seen this mentioned elsewhere). It can be observed by running a speed test (best to use an exe/app). You will only reach about 90% of maximum and speed falls backward halfway through. You will also experience moderate latency issues on Twitter, etc.

v17.01.6 (LEDE) works like a charm. I'm really hoping that they get the bugs worked out on this router. It looks nice, it smokes on both ethernet and wifi, and you can get one for practically nothing.


#14

@Paul_Ramone, you may wish to make a Bug Report (especially regarding 18.06.2 flashing).


#15

I upgraded from v18.06.1 to the latest stable build, v18.06.2, without any issues. Latency seems a bit better but I can't get pass 20Mpbs. What a pity! My actual broadband is 35Mbps.


#16

@tallpilot, too late. Lol. I bought a used WRT1900ac already. This one looks like a beast. I tried it with one of the snapshots before the latest 18.06.2 stable release. It worked well for about a week, then the router overheated. Just my luck! Anyway, I packed it aside for a few days and I am trying it out this SDaturday morning with the v18.06.2. Quick question(since this thread is about the EA3500), @mike or anybody else, does the internal fan on the WRT1900ac work with Openwrt? Thanks guys.


#17

I've never had a 1900 and my 1200 doesn't have a fan, so I've never really looked into it, but I do remember there was a cron job to call this script for the wrt models that had fans when they were first being supported by Openwrt, but I'm not sure if it's still necessary on the newer releases, if you don't see it in Luci>System>Scheduled tasks I'm guessing it's no longer needed and the fan should work fine.


#18

It's been mentioned on a few forums, I think they're aware that 18.06.2 not being compatible. I'm not so sure that the bug in 18.06.1 that causes some intermittent (but fairly frequent) latency issues. It's the kind of hiccup that will screw up a live game when it happens at the right time.

I'm very happy with LEDE 17.01.6. You just have to install luci-ssl via telnet and reboot to get the web interface. I upgraded all packages without a hiccup.


#19

@Paul_Ramone, I tried LEDE 17.01.6 at some point. Even compiled my own version with LUCI preinstalled. Can't remember what issue(s) I had with it. Will try again at some point.


#20

@mike, yes the script is there. Maybe the fan isn't working. Will check it out. In the meantime, I have attached a large 120mm fan(from an old power supply) on top. Not taking any chances. Thanks for the guidance, bruh.