Linkit Smart 7688 wifi not working

I installed LEDE 17.01.6 r3979 on my Linkit Smart 7688 and configured Wifi as it was configured in the offical build from Mediatek Linkit because this tutorial did not work as well. I then activated it with uci commit network, uci commit wireless then made a terminal reboot & uci wifi shows a answer: wlan0: link is not ready
This is my config:
/etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd5c:4b39:4236::/48'

config interface 'lan'
        option ifname 'eth0'
        option force_link '1'
        option macaddr '9c:65:f9:28:e3:4d'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.100.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '0'

config interface 'wan'
        option proto 'dhcp'

/etc/config/wifi:

config wifi-device 'radio0'
        option type 'ralink'
        option variant 'mt7628'
        option country 'TW'
        option hwmode '11g'
        option htmode 'HT40'
        option channel 'auto'
        option disabled '0'
        option linkit_mode 'sta'

config wifi-iface 'ap'
        option device 'radio0'
        option mode 'ap'
        option network 'lan'
        option ifname 'ra0'
        option encryption 'none'
        option ssid 'LinkIt_Smart_7688_28EFCD'
        option seq '1'

config wifi-iface 'sta'
        option device 'radio0'
        option mode 'sta'
        option network 'wan'
        option ifname 'apcli0'
        option led 'mediatek:orange:wifi'
        option ssid 'gruenewiese'
        option key ‚password‚
        option encryption 'psk2'

for simplicity here my uci show
whats wrong? how can i fix that?

The Mediatek repo is wildly outdated and should not be used, nor will it work with current kernels.

Anything based on that repo, likely including your linked tutorial, is likely wildly outdated and not applicable as well.

The approach I'd suggest is to:

  • Flash 18.06.1 or later from the official OpenWrt downloads
  • Do not save configuration
  • On boot, a default configuration will be present
  • If you have installed a snapshot, you can install LuCI if you desire
  • Start from that fresh configuration with hints from https://openwrt.org/docs/guide-quick-start/begin_here
1 Like

edit: found out that a reboot shows the desired 18.06.2 verison.
With a breakoutboard i now configured wifi but it seams as if i do not have access to the luci config tool over wifi. Do i have to configure access to the webinterface for wifi separately?

Does there exist any drawing that shows in which order Interface/Wireless/Routes/Switches/firewall are applied?

for all future people that search for the solution:

setup wifi Accesspoint

I show you how to configure wifi of Linkit Smart 7688 to work after reflashing a new firmware to the device. Because of the fact that the Linkit Smart 7688 does not have a Ethernet port and openWRT is built to be configured over LAN its tricky to configure WIFI, but possible.

  • download the firmware and rename the .bin to lks7688.img
  • copy the firmware to FAT32 formated USB drive
  • connect the USB drive with the Firmware to the Host port.
  • you have to use serial connection over RX2/TX2
  • find out the name of the serial device on your computer with $ls /dev/tty.*
  • sudo cu -s 57600 -l /dev/<yourDeviceName>
  • press reboot MPU on the Linkit Smart 7688
  • press keyboard number 5 in serial-terminal on your computer
  • wait 5min and then reboot hard (power down for 20s.)
  • reconnect serial connection and wait until its done with the bootsequence
  • press Enter
  • type $uci set wireless.radio0.disabled='0'
  • and $uci commit
  • then $reboot

now you can connect to a Wifi Accesspoint called 'openWrt' and after connecting the LUCI web interface can be reached over 192.168.1.1 where you can configure your wifi.

how to connect to a local Wifi

https://openwrt.org/docs/guide-quick-start/basic_wifi

THIS IS QUITE GOOD:
https://openwrt.org/docs/guide-quick-start/walkthrough_wifi

BE AWARE THAT THIS MANUAL IS MAINLY FOR PEOPLE THAT SETUP A ROUTER AND WHANT IT TO PROVIDE WIFI AS ACCESSPOINT.
YOUR DESIRE MAY BE THE OPOSITE AS THE LINKIT IS MORE A CLIENT NODE.

THE MOST IMPORTANT THING IS TO SET THE COUNTRY CODE!

2 Likes