Lets talk about usteer

Who has tried it? What tips do you have to share with the community?
I've started a wiki page with all of the information i've gathered by playing with it so far, but i'm stabbing pretty blindly.
I haven't got band steering working properly yet, but sharing connected client information across the network is seamless and works with minimal effort.

Looking forward to the community contributing.

@tmomas I think i've created the page in the wrong space, i intended for it to be in the wiki. If it's in the wrong space can you please assist me in relocating it? Thank you

3 Likes

@bobafetthotmail Can you please take a look?

1 Like

How well does it work? I remember seeing a post somewhere about the fact that it doesn't work at all, at least when it comes to the actual steering part.

Not yet, but i'm not sure i've got a good setup for it. I'm in a scenario where the overlap of my APs is too high in some places and not enough coverage in others. So i end up with devices that can't decide between two equally terrible options.
I think i need to play with tx powers, then try steering

2 Likes

Hello,

I have two Belkin RT3200's (They show up as Linksys E8450 (UBI)).

I'm trying to configure usteer based on the wiki referenced above but when I put the https://openwrt.org/usteer#configure_80211k_and_80211v_on_all_ap-nodes settings in for the ssid's then when I restart the network those wifi radios don't come up. They are disabled..

Any suggestions on how I would debug that?

I'm running OpenWrt SNAPSHOT r19175-ffa1088f63 / LuCI Master git-22.058.70382-d29400e

Check the logs after restarting the wifi and look for hostapd complaining about something

1 Like

Add in the section "Install and configure required packages" that you should remove/uninstall the wpad-basic-wolfssl (or wpad-basic) package and install the full version of wpad:

  • wpad-wolfssl
    or
  • wpad-openssl

Tip from @daniel to solve your problem

1 Like

I found the following two options were causing a problem.

option bss_transition '1'
option wnm_sleep_mode '1'

Neither of those options were recognized by hostapd. I replace bss_transition with ieee80211v and I just removed the wnm_sleep_mode entry.

This is a snapshot release that will eventually become 22

Any other thoughts? I think it's working..

root@OpenWrt:~# grep rrm /var/run/hostapd*
/var/run/hostapd-phy0.conf:rrm_neighbor_report=1
/var/run/hostapd-phy0.conf:rrm_beacon_report=1
/var/run/hostapd-phy1.conf:rrm_neighbor_report=1
/var/run/hostapd-phy1.conf:rrm_beacon_report=1

That doesn't sound right on the snapshot?
https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=b518f07d4b8ae144453c606c9ec4ecef7d39f968
That commit removes ieee80211v option.