LEDE sends Netgear R6220 in bootloop

Hi there,
I bought my second Netgear R6220 and also tried to flash with LEDE snapshot.
I used this instruction: Installing LEDE on a Netgear R6220.
The first R6220 was flashed sucessfully and is still running (Snapshot of 2017-06-10). Sadly I gave it away!
I bought a second one and also tried to flash the Snapshot version of 2017-06-10, 2017-08-08 and 2017-08-10 with previous SHA256 check and with different USB sticks. Everytime after reboot the router gets stuck in a bootloop (and got recovered by using NMRPFlash).

Is there anything I can do to help to get LEDE working on every R6220? I think they might have different hardware versions which cause problems.

Maybe this helps someone:

I've just picked up one of these. I'll crack it open to check the version of it. Looks like the CPU has been sanded, but if it's the same, then its the 1C2T version of the chip. I'm willing to help out on this one as far as I can, but it would be nice to see if this one can work. From reading the other threads it looks like there's a couple of different versions and flash layouts for this model.

What version does the lable on the case state? Also v1.2?

The chip in the center of the picture is not sanded, but they put some kind of sandstone with some adhesive on it (i think for thermal reasons).
It could remove the stone,it's a Mediatek MT7621ST

The back/cover of the Netgear R6220 does not say anything, that it's v1.2. Only the sticker on the inside tells that.

I read out the mtd partition sizes (you never know :wink: ), but they seem to be big enough for the images.

# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00100000 00020000 "Bootloader"
mtd1: 00100000 00020000 "SC PID"
mtd2: 00400000 00020000 "Kernel"
mtd3: 01c00000 00020000 "Rootfs"
mtd4: 00200000 00020000 "English UI"
mtd5: 00200000 00020000 "ML1"
mtd6: 00200000 00020000 "ML2"
mtd7: 00200000 00020000 "ML3"
mtd8: 00200000 00020000 "ML4"
mtd9: 00200000 00020000 "ML5"
mtd10: 00100000 00020000 "Factory"
mtd11: 00100000 00020000 "SC Private Data"
mtd12: 00200000 00020000 "POT"
mtd13: 00200000 00020000 "Traffic Meter"
mtd14: 00200000 00020000 "DPF"
mtd15: 00200000 00020000 "SC Nvram"
mtd16: 00200000 00020000 "Ralink Nvram"
mtd17: 00200000 00020000 "Ralink Reserved"
mtd18: 00200000 00020000 "ML6"
mtd19: 00200000 00020000 "Upgrade Flag"
mtd20: 00200000 00020000 "Reserved Block3"
mtd21: 03c00000 00020000 "Reserved Block4"

From the spec sheet, the MT7621ST should be 1C/2T (Single Core, Dual Thread). Would be interesting to see if it would be possible to run this a a multithreaded processor. I haven't had time to pull the box and check inside, but I'll post when I can find something out.

I have some news. I could get the Netgear R6220 router which is working with LEDE. I cracked it open and....tada.....it's Revision 1.4. On the inside there's a mark on the case which says that the case of the router was manufactured on March 2017.

So a closer look on the chips revealed the following differences:
Version 1.2

  • Main chip: Mediatek MT7621ST 1427-AMSH
  • Wireless chip: Mediatek MT7603EN 1508-BMAL
  • LAN chips: HN4821CG 1437

Version 1.4

  • Main chip: Mediatek MT7621ST 1606-AMTH
  • Wireless chip: Mediatek MT7603EN 1602-BMJL
  • LAN chips: HN4821CG 1601

And so again, I could not spot any difference from the outside of the router, but luckily you can place a strong light directly to the case (like a smartphone LED) and see the sticker with the Version number because the router case is just tinted.

Mine says V1.3

Ive always had issues trying to run LEDE on this router