Lede 17.01.4 on wrt54g3gv2-vf: usb ports have no power

Hello to all,

I'm new to LEDE but have some experience with DD-WRT on WRT54GL which is setup as a repeater.

Recently I found an old WRT54G3GV2-VF router that has much more memory and also 3 USB ports
and I thought I could use it to replace the WRT54GL and also attach storage to it in order to share it over the LAN and maybe also install a media server onto it.

But after flashing LEDE 17.01.4 I checked everything was fine except the USB ports which have no power!

I tried to activate them using GPIO's according to the below thread but it didn't work:

I also found this but didn't try it yet as I'm not very sure about what it is supposed to be doing:

I also tried all available versions of LEDE from here: https://downloads.lede-project.org/releases/

But none of them did the trick - instead some of them even broke down the WIFI.

So, I'm definitely out of clues right now thus any help will be very much appreciated,
Thank you in advance.

  • Are you sure that your device provides power at the amperage needed to run your storage device?
  • If so, are you certain that the WRT54G3GV2-VF's power can be activated via GPIO?
  • Yes, I'm sure, because I've tested it before flashing and my 2.5'' drive spinned up properly,
    except that with the original Linksys firmware, only 3g USB sticks were supported, no storage devices,
    this was the main reason I decided to switch from the stock firmware.

  • No, I am not certain that the WRT54G3GV2-VF’s USB ports can be powered up via GPIO,
    I just tried it according to the relevant wiki page, it was the only hint I came across after a lot of Googling.

Hello again, this is what I've accomplished so far:

  • Find the total number of GPIOs:

    root@LEDE:~# cat /sys/class/gpio/gpiochip0/ngpio
  • Get current GPIO's state:

    root@LEDE:~# cat /sys/kernel/debug/gpio
    GPIOs 0-15, ssb_chipco_gpio:
     gpio-1   (                    |bcm47xx:unk:power   ) out hi
     gpio-2   (                    |bcm47xx:green:3g    ) out lo
     gpio-3   (                    |bcm47xx:blue:3g     ) out lo
     gpio-5   (                    |gpio-keys           ) in  hi
     gpio-6   (                    |gpio-keys           ) in  hi
  • So, #4 is unused and I wanted to create it:

    root@LEDE:~# echo 4 > /sys/class/gpio/export
  • Get it's current value:

    root@LEDE:~# cat /sys/class/gpio/gpio4/value
  • Try to set it to 1 just to see if something happens:

    root@LEDE:~# echo 1 > /sys/class/gpio/gpio4/value
    **-ash: write error: Operation not permitted**

This error appears for every unused GPIO from 0-15.
How do I overcome this error?

PS: For the used ones (1,2,3,5,6) the export command does not work:

root@LEDE:~# echo 1 > /sys/class/gpio/export
-ash: write error: Resource busy

Did you build the firmware yourself?

The WRT54G3GV2-VF is not supported...


You have to write "out" to direction before a value can be written to appear on the pin. By default a pin is in input mode and value is read-only.

echo 4 > /sys/class/gpio/export
echo out > /sys/class/gpio/gpio4/direction
echo 1 > /sys/class/gpio/gpio4/value

GPIOs that are already claimed in the kernel build (for LED's etc) cannot be manipulated through this method.

I think the USB ports are only USB1, so if you do get it working, storage performance is going to be very low.

It is. Just updated the dataentry https://openwrt.org/toh/hwdata/linksys/linksys_wrt54g3gv2_10 (was shown as not supported since firmware download image was missing in the old OpenWrt wiki).

No, I did not build anything on my own,
I first tried with a ready-made image from the downloads


initially based on the info from this page:


But after I flashed the image file openwrt-wrt54g3gv2-vf-squashfs.bin
I found that wifi was not working at all with version 10.0.3
so I continued searching in the downloads for newer versions,
where I found the below link with an image for WRT54G3GV2-VF:


With this version everything seems to work except usb ports.

Thank you, i will try this as well.

By the way, according to the manual there are 3 x USB 2.0 ports: