Lcdproc phantasmagoria

Hello community!

I am running OpenWrt 21.02.3 on Watchguard Firebox X750e Core (target — x86-generic). Everything's great, except lcdproc refuses to work.

I installed the lcdproc-server, lcdproc-clients, and lcdproc-drivers. At installation, the system has determined (correctly, it seems) that the applicable driver is sdeclcd. After istallation, I uncommented Hello and Goodbye lines in /etc/LCDd.conf (start simple, right?), but I am yet to see those lines on the LCD. Was there a configuration step I missed?

Trying to debug the issue led to an interesting realization. When I run service with no arguments, all LCD-related services (lcdexec, lcdproc, lcdvc) are shown as enabled (which is good) and stopped (which is bad). But if I immediately run, say,

service lcdproc status

it returns running. Same with the other two services. So it would seem the system is of two minds about whether services are running or not. So who's crazy, me or the Firebox? More importantly, how do I make the Hello and Goodbye lines show on the LCD?

Thank you in advance for any ideas!

guess conf should look similar to

Used the exact config file you suggested, with one correction: changed /usr/local/lib/lcdproc/ to /usr/lib/lcdproc/ where the drivers are on my device. No joy.

Dug a little deeper and found that even though the system selected the sdeclcd driver, there is no in /usr/lib/lcdproc/.

Found a on, installed in /usr/lib/lcdproc/, rebooted. Still no joy.

Clearly, I am missing something...

Problem solved. Found the correct driver here:

copied it into /usr/lib/lcdproc/, changed permissions to match surroundings (0755, owned by root:root), et voila!:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.