Latest snapshot degrades mt7915

Sometime between r23401-a860e439ed and r23453-5af7d47cd7 (between a week ago and yesterday) something has severely degraded my mt7915 card. In STA mode it's not negotiating anything higher than the most basic rate:
Depending on the AP I'm connecting to, sometimes the RX rate will negotiate to something proper, but the TX rate never does.

Also there is always a delay - it never connects at a high rate. Even if the RX rate does go to something that I'd expect, it first connects at 6.0 Mbit/s and then after a minute or so negotiates something normal.

Builds a week ago or earlier produce normal connection. This is connected to the same AP 30 seconds later after swapping sdcards to an older build:

It connects immediately at rates I would expect.

There is a huge mt update commited several hours ago - give it a try :;a=commit;h=01885bc6a33dbfa6f3c9e97778fd8f4f60e2514f
Good luck!

1 Like

AUC is showing major downgrades for me on all mt7915 modules from the 22nd June to 13th May 2023.

I'm checking this with AUC, so I'm going to skip snapshot until I see upgrades again.

I'm wondering if anything from the 23.05-rc2 builds has slipped through.

BusyBox v1.36.1 (2023-06-23 21:07:17 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _| |_______||   __|_____|__|__||________||__|  |____|          |__| W I R E L E S S   F R E E D O M
 ----------------------------------------------------- OpenWrt SNAPSHOT, r23428-b308bd50ef
 -----------------------------------------------------root@OpenWrt:~# auc
Running:   SNAPSHOT r23428-b308bd50ef on mediatek/mt7622 (netgear,wax206)
Available: SNAPSHOT r23453-5af7d47cd7
Requesting package lists...
 rpcd: 2023-03-14-d9788300-1 -> 2023-06-25-31c39072-1
 kmod-mt7622-firmware: 5.15.118+2023-06-22-29cfabbb-1 -> 5.15.118+2023-05-13-969b7b5e-1
 procd-ujail: 2023-01-16-190f13a7-1 -> 2023-06-25-2db83655-1                                           base-files: 1533-r23428-b308bd50ef -> 1533-r23453-5af7d47cd7                                          kmod-mt7615e: 5.15.118+2023-06-22-29cfabbb-1 -> 5.15.118+2023-05-13-969b7b5e-1                        procd: 2023-01-16-190f13a7-1 -> 2023-06-25-2db83655-1                                                 kmod-mt7615-common: 5.15.118+2023-06-22-29cfabbb-1 -> 5.15.118+2023-05-13-969b7b5e-1                  rpcd-mod-ucode: 2023-03-14-d9788300-1 -> 2023-06-25-31c39072-1                                        kmod-mt76-connac: 5.15.118+2023-06-22-29cfabbb-1 -> 5.15.118+2023-05-13-969b7b5e-1                    rpcd-mod-file: 2023-03-14-d9788300-1 -> 2023-06-25-31c39072-1                                         procd-seccomp: 2023-01-16-190f13a7-1 -> 2023-06-25-2db83655-1                                         kmod-mt7915e: 5.15.118+2023-06-22-29cfabbb-1 -> 5.15.118+2023-05-13-969b7b5e-1                        uhttpd: 2023-01-28-47561aa1-1 -> 2023-06-25-34a8a74d-1                                                kmod-mt7915-firmware: 5.15.118+2023-06-22-29cfabbb-1 -> 5.15.118+2023-05-13-969b7b5e-1                rpcd-mod-rpcsys: 2023-03-14-d9788300-1 -> 2023-06-25-31c39072-1                                       kmod-mt76-core: 5.15.118+2023-06-22-29cfabbb-1 -> 5.15.118+2023-05-13-969b7b5e-1                      rpcd-mod-iwinfo: 2023-03-14-d9788300-1 -> 2023-06-25-31c39072-1                                       luci-mod-network: git-23.170.81081-b2546c2 -> git-23.175.80454-fd5440a                                uhttpd-mod-ubus: 2023-01-28-47561aa1-1 -> 2023-06-25-34a8a74d-1                                      Are you sure you want to continue the upgrade process? [N/y]

Just tried it. No effect. Still the same problem.

I've just discovered that it also occurs on r23401-a860e439ed (a week old snapshot), so the last known working snapshot is some months old: 22257-166ab6f90e. I can't narrow it down any further.

I’ve already reported this regression and provided a temporary solution - Wireless client mode broken on WAX206 post r22866 - #8 by Wiz

I don’t believe the issue lies in @nbd update but in @blocktrron update… so revert both mt76 commits to get a working snapshot (I was not able to revert the mt76 update from mid-May without also reverting the latest one).

1 Like

I have identified the April 17th mt76 commit as the offending change. The previous commit (Mar 30) works.

I see that there were firmware updates for the mt7916, mt7921, and mt7922. I wonder if the mt7915 got missed and subsequent driver changes need that firmware. I'm investigating this now.


Wasn't firmware. It's this patch:

Reverting that corrects the problem.

EDIT: Latest changes on mt76 corrects the AP issue and mesh. There may still be a slow-down when mesh is used with a VAP on the same radio. I expect, though, that the latest mt76 will get pushed to openwrt master soon.