LAN + SIM MODEM Question

I have a GL-XE300 PULI with an AT&T SIM card. I want to use it as an access point in the field. I want to be able to plug into a customer network and create wifi from the customer port and access customer lan ips that are in the 10.237.195.x/24 range. Most customer networks have dhcp so i can just plug them into the WAN port of the PULI but i still want to use internet from the PULI AT&T sim card.

Now for arguments sake PULI is in router mode:
Lets say i plug into the customer network and they assign an IP to the WAN port of the PULI thats 10.237.195.37/24. If i plug into the LAN port of the PULI i get a 192.168.8.X on my PC now i can access IPs on the 10.237.195.37.x/24 too. But now my internet access i.e. google.com goes through the 10.237.195.37. How can i use the sim card thats inserted into the PULI as my internet access?

My idea is to turn off DHCP on the PULI LAN port (to avoid sending IPs to customer) and then change the static IP of the PULI LAN to 10.237.195.37. Then on my PC use 10.237.195.37 as my default gateway and DNS? If i go to a different site that uses a different IP address range then i would need to change the IP of the PULI again, so my other idea is leave the puli at 192.168.8.1 (dhcp off) then i can just use 2 ip addresses on my PC nic card but only 1 default gateway for the PULIā€¦

Is there a better way to accomplish this?

Also when i change the ip address of the PULI LAN i cant access the web GUI anymore.... ideas?

Below:

https://imgur.com/a/UQbkbBv

Set defaultroute and peerdns off on the Ethernet wan. A route to the customer's LAN will still be installed by DHCP when Ethernet is connected. Your Internet usage will be by cell.

Both the cell and the Ethernet should be in the WAN zone since unless the customer's router contains a route back to your 192.168.8.0 lan, the forwarding from the PC to the customer's LAN must be NATd.

Copy ill give that a shot. Where do i do the WAN zone part in luci?

Both the cell and the Ethernet should be in the WAN zone since unless the customer's router contains a route back to your 192.168.8.0 lan, the forwarding from the PC to the customer's LAN must be NATd.

Isnt this done inherently by my glinet router? Because when i ping and browse to customer IPs it works. I may be misunderstanding you. And thanks!

thanks for your help so far i think i got what you said to work. this is what i got: https://imgur.com/a/doW7zf9

question: Since default gateway/route is unchecked for the physical wan port that means i can only see IPs on that flat subnet? I can only PING 10.134.231.X network, when i try to ping a known webserver of 10.134.180.27 i get no reply. Is this because it doesnt know the route?

Is there a way for me to still see ALL customer IPS on their network while still utilizing my ATT as internet?

Last question is there a simple setting where i can pick which internet access route i want? Meaning the customer ISP access or my ATT access. Preferrably i want to do this selection from my PC thats connected to the PULI.

Yes if the DHCP issued a /24 then the automatic route only covers that /24. You could add a route for all of 10.0.0.0/8 via eth port since nothing on the Internet is in that subnet so an ISP (AT&T) will drop packets with any private destination IP.

Disable the LTE modem and re-enable use default route and peer DNS on the eth connection.

Thanks for all the help that works for my case.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.