Kuwfi CPE 830 recovery

Hi i am a new user and a noob don't know much about linux and programming, but advance user of windows and know lots about networking.

i have a router
KuWFi CPE outdoor


i have tried to load openwrt but it bricked i need to flash a firmware which i have already got that from there website but don't know how to do that in a manual way as like TFTP server

after researching everywhere i found some reference of


IP address for tftp is 192.168.0.141

as per procedure, i have tried through wan port
the flashing process, tftp server shows it ok and completed
but after rebooting it don't work. but the wifi and the blinking light is working
i am able to connect to wifi but stuck on obtaining ip address

there is a problem while flashing is i had to rename the firmware from (.ubin to bin)file
example upgrade.ubin to upgrade.bin i don't know what is the difference.
the stock firmware is upgrade.ubin but the device asking for only bin file

Is this step 7 of option 1 on the github? You are going to flash a release AP147 build. It is very important to confirm you transferred the file correctly (at the least do an ls /tmp and compare file size-- it would be even better to hash it with md5sum or sha256sum) before going to mtd flash it.

i have finally got the solution all credit goes to
grosjo (Joan Moreau)
he build the firmware and it all worked

To unbrick Kuwfi CPE830D
requirments -
lan cable
12v adapter
firmware (check for the link down below)
TFTP Server (google it and download it)

Instruction
Step 1. Change network IP address from adapter settings to 192.168.0.14,subnet mask 255.255.255.0 (bootloader listen server for kuwfi)

step 2. open tftp server chose the directory for the upgrade.bin wait

Step 3. plug the lan cable to pc and WAN port of the Kuwfi router.

step 4. hold the reset button and power on the router (hold the reset button for more then 22 sec)

Step 5. release the button and wait for 1 min or less and tftp server will flash the router.

Step6. after that wait 5 min let the router to intitalize change your network ipaddress to 192.168.1.2

Step7. open chrome and go for 192.168.1.1

here you go router is ready

https://github.com/grosjo/OpenWrt-Kuwfi-CPE830/blob/master/upgrade.bin

all credit goes to


reference link github(dot)com/grosjo/OpenWrt-Kuwfi-CPE830