Kernel Panic during my OpenWrt bootup period

Hi All,

My new built 19.07 image for Ath9k gets kernel panic during bootup period as below. Any thought? For example, could I debug init via log, etc? Thanks

[    2.947195] NET: Registered protocol family 10
[    2.957115] Segment Routing with IPv6
[    2.960942] NET: Registered protocol family 17
[    2.966109] 8021q: 802.1Q VLAN Support v1.8
[    2.975569] VFS: Mounted root (squashfs filesystem) readonly on device 31:3.
[    2.983739] Freeing unused kernel memory: 208K
[    2.988292] This architecture does not have kernel memory protection.
[    3.621419] here here Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000004
[    3.621419]
[    3.631580] CPU: 0 PID: 1 Comm: init Not tainted 4.14.254 #0
[    3.637317] Stack : 804e0000 80494e60 00000000 00000000 80472448 87c29d1c 87c242dc 804bd987
[    3.645814]         8046e4c4 00000001 805135f0 87c2a000 87c30000 00000001 87c29cd0 ba019014
[    3.654306]         00000000 00000000 80510000 00001a10 00000000 00000000 0000000f 00000000
[    3.662798]         00000060 4621ab02 0000005f 00000000 80000000 80470354 80510000 87c24000
[    3.671291]         00400100 87c2a000 87c30000 00000001 00000003 802483f0 0807a098 80510000
[    3.679783]         ...
[    3.682265] Call Trace:
[    3.684761] [<8006b8fc>] show_stack+0x58/0x100
[    3.689275] [<800864e4>] panic+0x104/0x290
[    3.693434] [<8008784c>] do_exit+0x180/0x8d8
[    3.697771] [<80088c60>] SyS_exit_group+0x0/0x14
[    3.703320] Rebooting in 1 seconds..

which device ?
which openwrt image did you use ?

Hi frollic,

Thanks for your reply. This is my a customised board upon Ather9344. It used to work with OpenWRT 15.03, now I am working to migrate it to OpenWRT 19.07.

I know it is hard to reach the root reason. Here I just wonder how I could debug such an issue. Thanks.

check out ignore_loglevel -

Thanks. However, as you know now I even couldn't get into the failsave mode. So it is impossible for me to set the parameter at the console. What I do is to change the
ignore_loglevel = true directly in the source code


So far seems that the console print is still as before. Any thought? Thanks

I would have passed it as a kernel boot param .... changing the source code, who knows.


Actually I got one stable 19.07 build which could generate a stable artifact without the kernel panic; however once I deleted the /staging_dir and let it rebuild again, I would get an unstable artifact with kernel panic as above.

Hi All,

Finally I figured this out. I had thought the CPU_TYPE in target/linux/ar71xx would still be compatible with 34kc, but it seems that in 19.07, the default 24kc would be more stable. Once I change the parameter to 24kc. The panic is just gone. Thanks again for your help, community.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.