Kernel config question - CONFIG_MAXLINEAR_GPHY=y

Hi there!

I have a question to understand better how it works.
In openwrt-23.05.3/target/linux/mediatek/filogic there is a file called "config-5.15" and i see a line "CONFIG_MAXLINEAR_GPHY=y" in it.

Just for testing I copied that file into .config and did a "make menuconfig".
However, I expected the things being written as "=y" showing up in the menuconfig, but they do not. After exiting menuconfig I didn't see those lines like "CONFIG_MAXLINEAR_GPHY=y" anymore in the .config file.

What am I missing? How do I include those things that are writting in filogic/config-5.15 in my .config? Especially I am trying to include the 2.5gb maxlineair gpy211 driver.
I am using a clean 23.05.3 gitcloned buildroot btw.

Thank you!

Most of all you're mixing up kernel kconfig and buildroot kconfig, OpenWrt (re-)uses kconfig to select features (~packages) for the project at large, so there are two distinct layers of different kconfig based configurations. For the main project (~buildroot) .config, all features need to be explicitly defined as (package-) config symbols, it does not directly provide access to the lower level of kernel kconfig (kernel_menuconfig) options, both are within different namespaces.

1 Like


I just did a "make kernel_menuconfig" and I see the kernel cfg i never seen before, very nice.
Are the settings in there ok for mt7981-rfb filogic just without me changing anything?

Oh, and where is its .config located? Is it this one?


When I have maxlineair gpy in the kernel config, does it still need to included in the main project .config?


Maybe (if you want to make it selectable from the main kconfig)…

Okay, then I have the answer to my question (how to include that gpy211 driver). I didn't know I could do a make kernel_menuconfig.
And now I do, thanks for help Slh!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.