Kernel 5.15 breaks smp packet steering

After I upgraded to 5.15 test kernel, smp packet steering did not work, all soft irq always bond to one core, it worked as expected after flashing back to 5.10 kernel.

My device is mikrotik hap ac2 with dsa patch and firewall4 used, I'm not sure it's a general issue or a platform specified issue or something else related to dsa patch, more tests on other platforms are welcome.

Now I can confirm openwrt version 498c15376b + kernel 5.15.45 + DSA patch has this issue, but 498c15376b + kernel 5.10.120 + DSA patch worked as expected.

What version of OpenWrt are you using?

latest git master.

...and it's version number?

(If you don't wish to share, that's OK; but as I recall, that's the most definitive way to identify everything in the build.)

1 Like

r19796+17-498c15376b + 5.10 kernel + dsa patch work as expected, I can confirm this.
But 5.15 kernel version was compiled from git several days ago, I'm not sure the version number.
Maybe it is related to

And if you compile an image without dsa patch?

Yes, the problem still exists without dsa patch, I think it's not caused by dsa patch.