I am having issues hopefully someone out there can help. Out of the box I have only assigned statics and set port forwards. 1 Lan client would not accept static (Raspberry Pi) but after reboot Pi it took, however its flapping and responds to between 4-6, then no pings for 4-6.
I turned IP6 off on interfaces also just in case but still no joy. Also Transfer from wired NAS is stuttering maybe every 5-10 mins for few seconds, maybe its related. Also my laptop will only connect to 2.4Ghz band, not an issue.
Just wondering is there any adjustment that could be made to get the lan port working reliably for the Pi?
Is the client that is having a problem wired or wireless? Are there any other clients having issues?
Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
OK details below. I tried ping from another LAN port also and same flapping. Can also see on the cgi-bin/luci/admin/network/switch page that port flaps between "no port" to "100baseT full-duplex"
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd2c:4254:dbb1::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0.1'
option ipv6 '0'
config device
option name 'eth0.1'
option macaddr '2c:30:33:f2:94:22'
option ipv6 '0'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr 'xxx.xxx.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'eth0.2'
option macaddr '2C:30:33:F2:94:23'
option ipv6 '0'
config interface 'wan'
option device 'eth0.2'
option proto 'static'
option ipaddr 'xxx.xxx.xxx.xx'
option netmask '255.255.255.0'
option gateway 'xxx.xxx.xxx.1'
list dns 'xxx.xxx.xxx.1'
list dns '8.8.8.8'
config interface 'wan6'
option device 'eth0.2'
option proto 'dhcpv6'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 5t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 5t'
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11a'
option path '18000000.axi/bcma0:7/pci0000:00/0000:00:00.0/0000:01:00.0'
option htmode 'VHT80'
option channel 'auto'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'xxxxxx'
option encryption 'psk2'
option key 'xxxxxxxx'
config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path '18000000.axi/bcma0:8/pci0001:00/0001:00:00.0/0001:01:00.0/0001:02:01.0/0001:03:00.0'
option htmode 'HT20'
option cell_density '0'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'xxxxxx'
option encryption 'psk2'
option key 'xxxxxxxxx'
config wifi-device 'radio2'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path '18000000.axi/bcma0:8/pci0001:00/0001:00:00.0/0001:01:00.0/0001:02:02.0/0001:04:00.0'
option htmode 'VHT80'
option cell_density '0'
config wifi-iface 'default_radio2'
option device 'radio2'
option network 'lan'
option mode 'ap'
option ssid 'xxxxxxxxx'
option encryption 'psk2'
option key 'xxxxxxxx'
root@OpenWrt:~# cat /etc/config/dhcp
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option localservice '1'
option ednspacket_max '1232'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
option ra_slaac '1'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
option start '100'
option limit '150'
option leasetime '12h'
option force '1'
list ra_flags 'none'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config host
option name 'RasbyPi'
option ip 'xxx.xxx.xxx.175'
option mac 'xxxxx'
config host
option name 'QNAS'
option dns '1'
option mac 'xxxxxx'
option ip 'xxx.xxx.xxx.197'
root@OpenWrt:~# cat /etc/config/firewall
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config rule
option name 'Support-UDP-Traceroute'
option src 'wan'
option dest_port '33434:33689'
option proto 'udp'
option family 'ipv4'
option target 'REJECT'
option enabled 'false'
config include
option path '/etc/firewall.user'
config redirect
option target 'DNAT'
option name 'internalweb'
option src 'wan'
option src_dport '9999'
option dest 'lan'
option dest_ip 'xxx.xxx.1.175'
option dest_port '443'
Another Pi connects via wifi no problem, just this one connected to LAN. I'm looking at this Pi and it looks like network is up/down. Pi has been fine on this router for years using stock firmware and also another opensource build
I took off the static for the pi and rebooted it and the router, still same behaviour, on different IP (from DHCP). Looks like there is some compatibility issue so will save config and reflash router back to stock.
maybe there is some low level compatibility issue. Can see from logs:
Sat Nov 27 20:40:19 2021 kern.warn kernel: [ 0.002949] CPU: WARNING: CPU(s) started in wrong/inconsistent modes (primary CPU mode 0x13)
Sat Nov 27 20:40:19 2021 kern.warn kernel: [ 0.002953] CPU: This may indicate a broken bootloader or firmware.
Sat Nov 27 20:40:19 2021 kern.warn kernel: [ 0.000000] Hit pending asynchronous external abort (FSR=0x00001c06) during first unmask, this is most likely caused by a firmware/bootloader bug.
Apologies for wasting your time, and thanks for all your help. hooked up a monitor, as it turns out, my pi was in a reboot loop, so absolutely nothing to do with router.
Buffering from NAS is due to wifi client stuck on 2.4Ghz. I changed my wifi adapter "preferred band" to 5Ghz but still only getting 2.4Ghz, but that is not for this thread. Thanks very much for your help