Issues with Ubiquiti Edgerouter {4,6P} E300

I recently acquired an Edgerouter 6P, and had some trouble installing Openwrt on it.

Basically it seems that USB support is still not included in the initramfs bootable recovery/install image, as noted here:

This was worked around easy enough, as the both lan and wan ports work, so I was able to copy in via scp the needed full sysupgrade image and sysupgrade it. Perhaps this could be fixed in the next release ?

I'm now experiencing a strange issue which I dont see/have on my x86_64 (stable) and filogic (snapshot) targets.
Basic functionality works fine. However, I'm attempting to set the er6 up as a wireguard client, routing its private network to the central wireguard server. I have got 3 or 4 boxes with the exact same setup, which work without issue.

For reasons which I have not yet ascertained, (proxy) arp is not working properly. On a working client, without any intervention from me, I have an entry in the wireguard peer in the neighbor table which looks like this:

A.B.C.D dev eth0 lladdr 00:DE:AD:BE:EF:00 REACHABLE

where A.B.C.D is the IP address of the remote wireguard peer, and 00:DE:AD:BE:EF:00 is the mac address of the WAN gateway address.

However, on the er6, I have this

A.B.C.D dev lan0 FAILED

And the wireguard tunnel does not come up, although everything else works
I can work around this by explicitly adding the mac address of the WAN gateway address thusly:

ip neighbor change A.B.C.D lladdr 00:DE:AD:BE:EF:00 dev lan0

Naturally, wireguard comes right up after doing this.

I'm at a complete loss to explain this behavior, as I dont experience this on the other platforms that I'm using.

Any hints appreciated.

Followup: This is working correctly in the lastest snapshot for this target (25 March 2023)