Issues with mounting USB drives and internet speed

I am using an Asus RT-AC2400 and I just installed openwrt for the first time. I used Asus Firmware Restoration and the RT-AC85P(which seems to be the same router but to what degree I have no idea) factory.bin. Setting up the pppoe connection and wifi went just fine but I have two issues:

  1. I can't get the USB HDD to mount. I tried following a video that follows the quick start guide but makes it easier for newbs using mostly just luci. HDD does not mount. I used two HDDs to be sure it's not a hardware problem.
    The HDD has 1 partition and I can see sda1 in luci. Anyway I press mount devices in luci and nothing happens.

I then tried to follow the guide on my own with SSH:

root@OpenWrt:~# ls -l /dev/sd*
brw-------    1 root     root        8,   0 Oct  2 01:45 /dev/sda
brw-------    1 root     root        8,   1 Oct  2 01:45 /dev/sda1
root@OpenWrt:~# block info | grep "/dev/sd"
/dev/sda1: UUID="F00EA5360EA4F72E" LABEL="New Volume" TYPE="ntfs"
root@OpenWrt:~# gdisk /dev/sda
-ash: gdisk: not found
root@OpenWrt:~# n
-ash: n: not found
root@OpenWrt:~# gdisk /dev/sda1
-ash: gdisk: not found

2.My internet speed is limited to 350-400Mbps and it was running just fine at 1Gbps before openwrt. The only thing I could find regarding slower speeds is SQM but it was not installed. I then installed luci-app-sqm to look at the settings and it's not enabled. When it's enabled connection gets marginally slower at 300Mbps. Are there any setting I can change to get the speed back up?


Welcome to the forum.

First of all, make sure your hardware is supported.
I do see the RT-AC85P in the ToH of OpenWrt, but not the RT-AC2400 (only a Netgear, without RT-)
But after some searching:
There is stated that several models are the same, also RT-AC2400 !

What video? From youtube OneMarcFifty it should be ok :slight_smile:

Check the following link if you missed something for default USB usage:

Did you add ntfs support as filesystem to OpenWrt?

Better try format your HDD fat32, or ext4.
(ntfs = dirty windows format ...)

About internet speed: SQM slows speed down, so why install it?

I guess your WAN connection is still 1Gbps connected with OpenWrt, only traffic over it is slower than OEM firmware.
Did you do same speed tests with OEM firmware and OpenWrt, what is the real difference?


I installed SQM to make sure it's turned off but the speed never went above 350-400Mbps before I installed it or after I did so. I get 1Gbps with stock firmware and I was also getting 1Gbps with my old RT-N18U, with stock firmware. I don't have any idea why the RT-AC2400 is slower with openwrt on it. Yes, WAN is still 1Gbps, traffic is slower.
Is there any on by default setting that might slow down the connection?

This is what I followed . I'm using NTFS because I'm using windows and I might just connect the HDD to my PC from time to time and fat32 has a file size limit. I added ntfs support as far as I can tell but I'll follow what you sent me regarding the USB after I figure out what what's causing the lower speed as I won't be using openwrt if I can't get the speed up.



If your router is connected to the HDD and also your PC, you should always have access to that drive, so why:

  1. unmount HDD from OpenWrt, make sure it's not connected to some other device/user (software)
  2. physically disconnect HDD from router
  3. connect HDD to PC

If your PC is already connected to (that) router and the HDD?

Also: with ntfs; someone is writing to HDD connected to router and you disconnect it for local PC usage, it will be unrecognized due to write errors. Good luck to restore that ...

Is the USB HDD bigger then 2TB or do you use files bigger than 4GB (DVD-iso's)?
Then get ntfs working on OpenWrt, otherwise I should use format fat32.

How do you check your internet speed? Using same hard- & software / browsers and tests?
What is the down- and upload speed of OEM firmware vs. OpenWrt? (screenshots?)
Which version of OpenWrt are you using ?

You never get the maximum speed what you pay for.
I pay for 100/20Mbps but get only 1/3 of download speed on all speed tests:

Upload even a little bit higher :slight_smile:
On other (own ISP) download is -ofcourse- 42 Mbps.

I've seen messages where speeds were pushed up by playing with these 2 options within Network / Firewall. The hardware must be able to support it, otherwise the speed will stay the same.

Maybe worth trying these. The second option comes up when selecting the first.


1 Like


I see something is not installed!

You typed gdisk, but that is not installed on your system.
Go to System / Software, then first click Update lists.

Type gdisk into filter and install it.

Then try your commands on CLI again.


With both flow options checked I now get the same speed with both OperWrt and the original firmware. My plan just got downgraded so I can't test higher speeds right now but I get 500Mbps both up and down. When I first posted I was getting 900Mbps on this connection with my 9 year old router and it never varied by more than 50-100Mbps so it was never a connection/hardware issue.
If possible and if it doesn't create other problems it might be a good idea to have these option be turned on by default in the factory build for routers where it is available though I'm not sure where else I could suggest that.

I have files larger than 4Gb. I would directly connect the HDD to the PC because it's a lot faster, if it proves to be faster with the newer router I won't do it. Also, in case the router doesn't work anymore I still have access to the files.
I was not aware of the potential issues with NTFS. Any reason as to why I can't/shouldn't use exFAT?

1 Like


I see, it's the Wifi -internal- speed you where writing about. I thought you meant the internet speed, but it's clear now :wink:
The max wifi speed is depending on all other devices using the same frequency (IoT, neighbor's, other Wifi, microwave, etc). therefore you have to do the tests on the 'same' time, not with a day in between .

I read somewhere that you need drivers for windows to get it working?
You can also try exfat as format.

But if the HDD fails you don't have any data ... Always have a backup!
I've seen ten times more HDD's fail in my life than routers!


No, the tests above were all done on lan. I don't use wifi to test internet speed :)), other than when I first installed OpenWrt I even ran two tests simultaneously on two machines (one on lan, the other on wifi) to test if it's a limitation per machine or if it is the internet connection and they were hitting about 170Mbps each so without Hardware flow offloading the internet connection speed is very much capped below 400Mbps, at least on the RT-AC2400.

I am aware HDDs fail more often, I just want to have options. I will try exfat later and tell you how it went.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.