Issues with 22.03 DHCP

Currently using OpenWRT ver 22.03.5 on a 4gb raspberry-pi4b
I'm hoping someone is able to help me with why my DHCP isn't serving any leases to my lan... I have posted my settings below for my network,dhcp, and logs from dnsmasq on restart.

it appears to be capable of serving my guest network but not my lan (though the guest network will decide to lose internet capabilities while still being able to serve addresses)
(i have to manually set the address' on my pc to even access the router)

I have, stubby, bcp38, mwan3,sqm installed as well if those can cause conflicts (they didnt seem to have any conflicts prior to this update~. )

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix '--::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '10.71.71.10'
        option gateway '192.168.0.1'
        option broadcast '10.71.71.255'

config interface 'wan'
        option proto 'dhcp'
        option force_link '1'
        option broadcast '1'
        option peerdns '0'
        list dns '127.0.0.1'
        option metric '10'
        option clientid '-'
        option device 'veth5'

config interface 'wan6'
        option proto 'dhcpv6'
        option force_link '1'
        option reqaddress 'try'
        option reqprefix 'auto'
        option peerdns '0'
        list dns '0::1'
        option metric '20'
        option clientid '-'
        option device 'veth7'

config device 'guest_dev'
        option type 'bridge'
        option name 'br-guest'

config interface 'guest'
        option proto 'static'
        option device 'br-guest'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'

config device 'veth5'
        option name 'veth5'
        option type 'macvlan'
        option ifname 'eth1'
        option mode 'vepa'
        option macaddr '-'

config device 'veth7'
        option name 'veth7'
        option type 'macvlan'
        option ifname 'eth1'
        option mode 'vepa'
        option macaddr 'E2:1E:B4:F8:CB:B5'


package dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '1'
        option ednspacket_max '1232'
        option noresolv '1'
        option dnssec '1'
        list interface 'br-guest'
        option confdir '/etc/dnsmasq.d'
        list server '127.0.0.1#5453'
        list server '0::1#5453'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'


config dhcp 'wan6'
        option interface 'wan6'
        option ignore '1'
        option master '1'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'

config dhcp 'guest'
        option interface 'guest'
        option start '100'
        option limit '150'
        option leasetime '1h'
        option netmask '255.255.255.0'

config host
        option mac '-'
        option ip '10.71.71.10'

udhcpc: started, v1.35.0
udhcpc: broadcasting discover
udhcpc: no lease, failing
udhcpc: started, v1.35.0
udhcpc: broadcasting discover
udhcpc: no lease, failing
Fri Jun  2 20:19:33 2023 user.notice dnsmasq: DNS rebinding protection is active, will discard upstream RFC1918 responses!
Fri Jun  2 20:19:33 2023 user.notice dnsmasq: Allowing 127.0.0.0/8 responses
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: started, version 2.86 cachesize 150
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth cryptohash DNSSEC no-ID loop-detect inotify dumpfile
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: DNSSEC validation enabled
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: DNSSEC signature timestamps not checked until receipt of SIGINT
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: configured with trust anchor for 
Fri Jun  2 20:19:33 2023 daemon.warn dnsmasq[1]: warning: interface br-guest does not currently exist
Fri Jun  2 20:19:33 2023 daemon.warn dnsmasq[1]: warning: interface br-lan does not currently exist
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: using nameserver 127.0.0.1#5453
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: using nameserver ::1#5453
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: using only locally-known addresses for test
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: using only locally-known addresses for local
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Fri Jun  2 20:19:33 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: started, version 2.86 cachesize 150
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth cryptohash DNSSEC no-ID loop-detect inotify dumpfile
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: DNSSEC validation enabled
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: DNSSEC signature timestamps not checked until receipt of SIGINT
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: configured with trust anchor for 
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 192.168.3.100 -- 192.168.3.249, lease time 1h
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 10.71.71.100 -- 10.71.71.249, lease time 12h
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using nameserver 127.0.0.1#5453
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using nameserver ::1#5453
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using only locally-known addresses for test
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using only locally-known addresses for local
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 3 addresses
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: started, version 2.86 cachesize 150
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth cryptohash DNSSEC no-ID loop-detect inotify dumpfile
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: DNSSEC validation enabled
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: DNSSEC signature timestamps not checked until receipt of SIGINT
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: configured with trust anchor for <root> keytag 20326
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 192.168.3.100 -- 192.168.3.249, lease time 1h
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 10.71.71.100 -- 10.71.71.249, lease time 12h
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using nameserver 127.0.0.1#5453
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using nameserver ::1#5453
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using only locally-known addresses for test
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using only locally-known addresses for local
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 3 addresses
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 3 addresses
Fri Jun  2 20:19:43 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Fri Jun  2 20:20:26 2023 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-guest) 192.168.3.100 
Fri Jun  2 20:20:26 2023 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-guest) 192.168.3.100 
Fri Jun  2 20:20:51 2023 daemon.info dnsmasq[1]: now checking DNSSEC signature timestamps
Fri Jun  2 20:20:51 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Fri Jun  2 20:20:51 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 3 addresses
Fri Jun  2 20:20:51 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Fri Jun  2 20:20:56 2023 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-guest) 78:66:9d:bd:a9:3b
Fri Jun  2 20:20:56 2023 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-guest) 192.168.3.190 
Fri Jun  2 20:20:56 2023 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-guest) 192.168.3.190 
Fri Jun  2 20:20:56 2023 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-guest) 192.168.3.190 
Fri Jun  2 20:21:50 2023 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM

maybe due to:

I think dnsmasq restarting does that.

image

the interfaces appear to be active asfaik

The gateway here is wrong. Is this device the router or is there another gateway?

The gateway has been corrected thank you so much for catching that, however the DHCP lease still refuses to function for the lan device :confused: I dont understand how the guest device has a dhcp lease but my lan is... not getting a lease

You have list interface ‘br-guest’ , you need list interface ‘br-lan’ too?

2 Likes

Perhaps because you instructed DNSMASQ to only serve a specific interface?

3 Likes

Yes either add br-lan to the list in the main config dnsmasq block or (preferably) remove any interface list-- which by default causes dnsmasq to listen on all interfaces (then e.g. for wan, it can be disabled with option ignore 1 or option dhcpvX disabled)

3 Likes

Thank you guys so much, that fixed the lease not being served!

I dont know how I even missed that, it used to automatically put the lan into the list prior to this update iirc.

Thanks again :heart:

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.