Issue with Tp-Link Archer C20 V5 ISP customised router (Indian ISP ACT Fibernet)

My router labelled as Archer C20(INACT) ver 5.0 unlike US or EU written on the label.

IN - India Region

ACT - Major ISP service based in India. So, my router is a ISP-Customised Router

Firstly I tried installing the Indian version of Factory Stock Firmware into my router to get rid of the blockade created by my ISP which blocks me from connecting to other ISPs as my router works with only ACT ISP with customised firmware built for my ISP. But it didn't work. All the LEDs just blink all the time after installing it with TFTPD64.

Next I tried installing other customised openWRT firmware available on the Internet for my router Archer C20 V5 but none of them worked.

Next I tried installing it with openWRT Archer C20 V4 and it worked. I have seen few posts in OpenWRT forums where many people installed V4 version in V5 router.

But, still Im not satisfied with this cuz even though the V4 openWRT firmware working fine, I would like to check how V5 openWRT version works on my device. But most importantly Im struggling to install openWRT C20 V5 versions into my router.

So, any suggestions or help for cases like mine?

Sorry about your C20 V5 failures. Please post a detailed log of your C20 V5 openWRT installation attempts.

Good luck.

Amat

Now, I am using Archer C20 V4 version openWRT firmware on my C20 V5 router. There are few hiccups while using my router as Wifi Repeater wirelessly. There are constant disconnections periodically. Can I continue using this with some workarounds? [ Despite network issues the ad-block has been working flawlessly]

So, about various installations : I have tried Linaro's latest(June 2022 probably) openWRT firmware from his Github and few other but after installation, it causes my router either Constant POWER LED light ON or Blinking of LEDs with orange light at the end. So, as I mentioned above both Factory images of V4 and V5 cause the same. Blinking of all LEDs. I guess there's something to do with customised router of mine done by ISP.

Where can I find logs of Installation?

There aren't any, you need to have serial port access while doing the actual flash.

I am a newbie. I dunno what is serial port access. And I have installed using Windows system. not linux system

OS doesn't matter, but you'd have to open your device, and in worst case, do some soldering.

You also need an USB TTL serial port.

Sorry but Why do I have to do soldering? I don't have any knowledge on soldering and its advantages

because there's (often) no other way to read the console output, but it depends on the PCB.

that's why I said in worst case.

1 Like

Hmm, I want a solution which involves working only with software if possible cuz I don't know have time to learn the hardware methods though I am willing to learn.

Then you need to buy a different device.

Which software are you using?

Amat

I am currently running my Archer C20 V5 router using archer c20 V4 openwrt firmware.

Which software did you use to install OpenWRT C20 v5 firmware?

Amat

The V5(EU) is the same chipset as V4, but different partitions and bootloader. Since it's the same chipset, there wouldn't be any performance difference with the V5 firmware, if it could run at all.

Likely what you have is more like a V4 than a V5.

1 Like

archer c20 v4 firware openwrt

Yea. I feel lucky for this to happen. Atleast I am able to make use of my router which was only meant for my old ISP. Now I could able to use this as my new Wifi Repeater but router is inconsistent when I enable both Bands i.e., 2.4GHz and 5GHz. Right now, I have only used it as repeater. I dunno if this will occur if I use this as Wifi Bridge. Do you have any solution for this?

Archer C20 v4 firmware offers a logging option. Please click system tab and click system on the pull down menu.

Amat


What I should do in this page?

Please read https://openwrt.org/docs/guide-user/base-system/log.essentials for details.

Amat