Issue with removing OpenWrt from WRT1200AC

Recently I attempted to remove OpenWrt from my WRT1200AC router as it was causing issues with forwarding ports and wanted to go back to DD-WRT. Upon searching for the instructions on how to remove OpenWrt from the router, I made a mistake and looked up the wrong instructions, inadvertently switching the partitions on the router back to the regular firmware on the router instead. Upon doing so, assuming that I had succeeded in removing OpenWrt, I attempted to flash the new firmware onto the router, only to find that the factory firmware was still on there. When I realized my mistake, I attempted to go back to the other partition with OpenWrt on it to perform the removal correctly, but found I was unable to do so. The router itself is still functional with the factory firmware still installed on it, but I can't install OpenWrt or any other firmware on it. I can't telnet into the router either, and I tried to do the power switch trick to switch the partitions, but it didn't work. I have no idea what to do now to fix this problem.

This may mean that the "other" firmware is not booting.

If the OEM firmware is running successfully, you should be able to install OEM firmware on the other partition, or follow the "first-flash" instructions for OpenWrt (or another third-party's firmware). What errors do you see if you try that?

1 Like

I don't get any error messages. It just drops right back to the OEM firmware as if nothing happened.

What does not generate an error message?

  • OEM -> OEM
  • OEM -> OpenWrt(factory)

I don't know, both I guess? If I had an error message I'd give it to you, but my router isn't giving me one.

Do you have serial access to the device?

If not, I'd recommend ordering an appropriate, 3.3 V serial-to-USB adapter (if it doesn't say 3.3 V, a "TTL" or "RS232" adapter will likely fry your router) and whatever pins or wires you'd need to use it.

I assume by serial access you mean I have to take apart the router, unless there's another way of doing that without disassembling it?

And is that the only way I can fix this?

The OEM firmware runs, that is good. Use it to flash another copy of the OEM firmware. You would then have OEM in both partitions. Then go to the ddwrt site and follow their instructions to install ddwrt.

The initial install of any third-party firmware should always start from OEM, not a different third-party.

1 Like

So flashing the OEM firmware again will write it to the other partition?

Flashing always goes to the other partition; ergo the reason for my above query.

1 Like

Flashing the OEM again actually solved my problem. Thank you very much.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.