I'm having issues with my PS5 and its usage of IPv6 DNS requests. When trying to connect to FC24 online, for example, the following error is thrown:
Server connection not possible Error WV-109144-9
ERROR 0x00000006 Couldn't resolve host name
From what I've gathered online, this is due to issues with the IPv6 DNS requests not resolving correctly and people can fix the issue by disabling IPv6 in its entirety; this isn't something I'd like to do though.
So a few questions:
Is it possible to disable IPv6 for a single device only?
If not, is there a way to debug what may be causing the DNS resolution failures?
A current workaround is to connect the PS5 to my phone, load up FC24 and then connect back to the WiFi. This isn't the only issue, as the PS Store also struggles to resolve images on the store and load content.
You can view how my WAN connection is setup here: PPPoE with IPv6 results in `Unknown error (HANGUP)` - #11 by MrAlex94 .
brada4
September 3, 2024, 7:24pm
2
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
root@OpenWrt:~# ubus call system board
{
"kernel": "6.6.47",
"hostname": "OpenWrt",
"system": "ARMv8 Processor rev 4",
"model": "Linksys MX4200v1",
"board_name": "linksys,mx4200v1",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "SNAPSHOT",
"revision": "r0-316341b",
"target": "qualcommax/ipq807x",
"description": "OpenWrt SNAPSHOT r0-316341b"
}
}
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdc7:e5ce:XXXX::/48'
option packet_steering '0'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '64'
option ip6hint '1'
config interface 'wan'
option device 'wan.101'
option proto 'pppoe'
option username 'XXXX'
option password XXXX'
option ipv6 'auto'
config interface 'wan6'
option proto 'dhcpv6'
option reqprefix 'auto'
option reqaddress 'try'
option device '@wan'
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/soc@0/c000000.wifi'
option band '5g'
option channel '36'
option htmode 'VHT80'
option country 'US'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'Baxendalia_Legacy'
option encryption 'sae-mixed'
option key 'XXXX'
option ocv '0'
option wpa_disable_eapol_key_retries '1'
config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/soc@0/c000000.wifi+1'
option band '2g'
option channel '11'
option htmode 'HE20'
option country 'US'
option cell_density '0'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'Baxendalia'
option encryption 'sae'
option key 'XXX'
option ocv '0'
option wpa_disable_eapol_key_retries '1'
config wifi-device 'radio2'
option type 'mac80211'
option path 'platform/soc@0/c000000.wifi+2'
option band '5g'
option channel '161'
option htmode 'HE80'
option disabled '0'
option country 'US'
option cell_density '0'
config wifi-iface 'default_radio2'
option device 'radio2'
option network 'lan'
option mode 'ap'
option ssid 'Baxendalia'
option encryption 'sae'
option key 'XXX'
option ocv '0'
option wpa_disable_eapol_key_retries '1'
root@OpenWrt:~# cat /etc/config/dhcp
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option cachesize '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option localservice '1'
option ednspacket_max '1232'
list server '127.0.0.53'
list server '127.0.0.53'
option confdir '/tmp/dnsmasq.d'
option noresolv '1'
option localuse '1'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
option ra_slaac '1'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config host
option mac '80:60:B7:8D:51:D5'
option nora '1'
option noslaac '1'
root@OpenWrt:~# cat /etc/config/firewall
config defaults
option syn_flood '1'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option flow_offloading '0'
config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config include 'qcanssecm'
option type 'script'
option path '/etc/firewall.d/qca-nss-ecm'
config redirect
option dest 'lan'
option target 'DNAT'
option name 'PS5 DMZ'
list proto 'all'
option src 'wan'
option dest_ip '192.168.1.146'
root@OpenWrt:~#
brada4
September 4, 2024, 7:21am
4
You need to ask about NSS build problemsi in NSS community build thread. On normal OpenWRT you would make guest network without ipv6
mk24
September 4, 2024, 2:41pm
5
Is this an attempt to not serve the PS5 with IPv6? If you have IPv6 working, it generally will be a better gaming experience.
Connect a phone or laptop to the lan wifi and run the test at test-ipv6.com .
Your configuration will use the DNS servers advertised by the ISP (and usually owned by the ISP). Run nslookup on the router to see if they resolve the sites of interest properly.
Yes, this was an attempt to stop the PS5 from getting an IPv6 address to fix the issue but unfortunately it doesn't work (still gets allocated an IPv6 address). Reverting this change doesn't do anything sadly.
I'll give nslookup a go and see if that fails on the router.
Edit: Just to note, the PS5 is the only device on my network struggling to resolve things (thumbnails on the PS Store, showing online status, playing some P2P games like FC24).