Issue with DNS & /etc/dnsmasq.conf

hi,
i have main router where i set
cat /etc/dnsmasq.conf
address=/phxxxx1.duckdns.org/10.0.1.104

from ssh i can easily ping phxxxx1.duckdns.org, which translates to 10.0.1.104
also i have clients connected via eth to that router and these clients can ping phxxxx1.duckdns.org

The issue is that i have 2 dumb APs and clients connected to these aps cant ping
phxxxx1.duckdns.org
even i cant ping phxxxx1.duckdns.org from ssh shell directly from APs, it says

ping: bad address 'phxxxx1.duckdns.org'

Any idea whats that?

Main router acts as DHCP server and also both dumb APs have set DNS server to 10.0.1.1
thanks

well i removed Use custom DNS servers from both dumb APs (from their wan interface)
so i left it empty and now clients on AP can connect to host
'phxxxx1.duckdns.org'

but there is other issue from i cant ping host
'phxxxx1.duckdns.org' directly from within shell of both APs
it shows still
ping: bad address 'phxxxx1.duckdns.org'

  • Is there a reason you're not using the OpenWrt syntax?
  • Is this the DDNS address of your router?

@lleachii what do u mean by openwrt syntax?

DDNS address of my router yes, its via dynamic dns.

hello,
any update here?

also when i connect to my main router via wireguard i cant access the mentioned host
https://phxxxx1.duckdns.org:8123

edit:
okay my wireguard has DNS set to 8.8.8.8
when i set it to the IP of my router, it all works fine.

If you can ping from eth, but not from a wlan, maybe you omitted something in your config. Can you share your:

  • /etc/config/network
  • /etc/config/firewall
  • /etc/config/wireless
  • (optionally) /etc/config/wireless

when i ping host using hostname from laptop it works okay (ping hostname)

when i execute the same ping from openwrt (extenders)
root@OpenWrt-ext1:~# ping xxx.xxx.org
ping: bad address 'xxx.xxx.org'

basically that hostname has to be resolved to IP address (thats how it works correctly from laptop but not from openwrt)

can I check what DNS is using that openwrt device that acts as dump AP (extender)
any idea?
thanks!

maybe the issue is that my openwrt extender is missing DNS of my local openwrt (main router)?
this is from openwrt extender>

maybe DNS servers dont have to be set on openwrt extenders (dump routers)?

To see what DNS servers you have set in a system cat /tmp/resolv.conf. You can also get useful information with nslookup xxx.xxx.org, about queries.

I'm thinking your wlan device is not connected properly to your main router, it's not bridged, or your firewall is blocking. But for need you should show your configuration, as I listed above.

@ambarusa

root@OpenWrt-ext1:~# cat /tmp/resolv.conf
search lan
nameserver 127.0.0.1
nameserver ::1

what do you mean by bridged? its connected like a client to router; maybe what you are saying is that in case its bridging traffic it should not use its own DNS setting but it should use DNS server which is set on main router?

So there's your main router, and the extender other side. They are connected via Wi-Fi right? The interface that handles on your main router is called wlan. Are you aware how is located this interface in your router, and what firewall rules are applying?
Examples:

From the first pictures you can clearly see that my lan interface is a Bridge, that contains multiple interfaces, ethernet inputs and wlans.

On your extender the wan interface should be connected to the main router, and see its received IP address from it.

hi,
well extender is connected via eth cable to main router where main router LAN is
image

on extender it looks like
image

I see. I believe the cable is plugged in an ethernet port on the main router, where is it plugged on the extender?

yes main router lan (Ethernet ports). Extender comes with its lan/ethernet port also its netgear ex6120.

Sorry, I've never tried using extenders. Universally speaking, to make sure correct DNS servers are set, I would try one of these (one at once):

  1. /etc/config/dhcp
config dhcp 'lan'
	...
	list dhcp_option '6,your_router_ip'      
	...
  1. /etc/config/network
config interface 'lan'
	...
	option dns 'your_router_ip'       
	...

For simplicity, restart these two services after either change, or just reboot:

service odhcpd restart
service network restart

You might want to check the OpenWrt documentation on WiFi extenders, repeaters, and bridge configuration -

well maybe the question is simple here.. does repeater require to have DNS set to IP of the main router? thanks

@OldNavyGuy
i dont use relayd .. just DUMB ap setup, but in relayd link u posted is stated>
(May be required in certain case) set Gateway address and Use custom DNS servers using IP address of the primary router (e.g. 192.168.1.1)

so it looks like DNS server on extenders/bridges has to be set to the primary router.

so am i correct? thx