Issue adding USB wireless adapter

I use a Raspberry Pi 3B+, installed OpenWRT with advised snapshot 'openwrt-bcm27xx-bcm2710-rpi-3-ext4-factory.img.gz' and LuCI. I could setup a STA with an excisting wireless network.
AP + STA is not supported (iw list).

I found information about using an Alpha AWUS036H with OpenWRT in USB Wireless adapter with OpenWRT .
I did:

opkg update
opkg install kmod-usb-core 
opkg install kmod-usb-uhci
opkg install kmod-usb-ohci
opkg install kmod-usb2

This was all successfull.
The following gave "failed to find usb-ohci etc. Maybe it is a built in module ?"

insmod usb-ohci
insmod usbcore
insmod uhci
insmod ehci-hcd

Next I installed the AWUS036H driver on OpenWRT with

opkg update
opkg install kmod-rtl8187

The test with the command "lsusb" if the driver is installed properly failed:

root@OpenWrt:~# opkg install kmod-rtl8187
Package kmod-rtl8187 (5.4.52+5.7-rc3-1-2) installed in root is up to date.
root@OpenWrt:~# lsusb
-ash: lsusb: not found

root@OpenWrt:~# iwconfig
-ash: iwconfig: not found

The wireless config is:
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'platform/soc/3f300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option htmode 'VHT80'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid 'Bacon'
        option key '88606798'
        option encryption 'psk2'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/3f980000.usb/usb1/1-1/1-1.1/1-1.1.2/1-1.1.2:1.0'

config wifi-iface 'wifinet1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option network 'lan'

Radio1 is not active and AP (master) is not associated.

Can somebody help me to make this working please?

1 Like

wifi status

tells there is a radio0
"up": true
"ifname": "wlan1"
"mode": "sta"
"ssid": "Bacon"
there is radio1
"up": true
there is no "ifname"
"mode": "ap"
"ssid": "OpenWrt"
there is radio2
"up": false
there is no "ifname"
"mode": "sta"
"ssid": "OpenWrt"

How can I remove radio2?
Do you have suggestions for me?

Plugging the adapter into different USB ports will create extra radios since they have a different hardware path. Always use it in the same physical port. Edit /etc/config/wireless to remove the extra wifi-device.


My USB wireless adapter works.
I cleaned up /etc/config/wireless, used radio0 als the master and radio1 (USB adapter) as the client.
So now I have a Raspberry PI 3B+ configurated as STA + AP.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.