Isp's pd changed but openwrt'pd not

Hi all.
I use isp's router pppoe, it get ipv6 pd /56
My openwrt version: 24.10.0 snapshot
My openwrt router'wan connect to isp'lan
openwrt wan6 interface use proto dhcpv6 client. It can get ipv6 address and a new pd /64 from isp' pd /56

The problem is:
When isp update the pd to a new one, my openwrt wan ipv6 can update to new, but pd not update automaticlly.
I have to restart openwrt wan6 interface.

So did I miss some config ?

Auto another problem.
After I restart wan interface, the lan interface get new ipv6, and in the luci's status page,

  • the active dhcpv6 leases show new statefull ipv6
  • associated station show new stateful ipv6
  • my clients like pc、phome、pad、pi get new stateless ipv6 and the old stateless ipv6 show deprecated, that's good
  • but pc、pi still hold old statefull ipv6, no new statefull ipv6 which show in luci's status page.

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export dhcp; \
ifstatus wan6
root@OpenWrt:~# ubus call system board
{
        "kernel": "6.6.79",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7620A ver:2 eco:6",
        "model": "Phicomm K2G",
        "board_name": "phicomm,k2g",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "firmware_url": "https://downloads.openwrt.org/",
                "revision": "r28914-be181cb3b3",
                "target": "ramips/mt7620",
                "description": "OpenWrt SNAPSHOT r28914-be181cb3b3",
                "builddate": "1740680685"
        }
}
root@OpenWrt:~# uci export network
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd50:3eca:ce72::/48'
        option packet_steering '0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '64'
        option gateway '192.168.1.1'
        option delegate '0'

config device
        option name 'eth0.2'
        option macaddr '98:bb:99:4c:e8:53'

config interface 'wan'
        option device 'eth0.2'
        option proto 'static'
        option ipaddr '192.168.1.100'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option norelease '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 6t'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6t'
        option vid '2'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '3 6t'
        option vid '3'

config interface 'local'
        option proto 'static'
        option device 'eth0.3'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'

config device
        option name 'eth0.3'
        option type '8021q'
        option ifname 'eth0'
        option vid '3'
        option macaddr '98:BB:99:4C:E8:55'

config rule6
        option in 'lan'
        option lookup 'raspberrypi'
        option mark '0x96'

config route6
        option gateway 'fe80::dee8:90e3:f752:a16'
        option table 'raspberrypi'
        option target '::/0'
        option interface 'lan'
root@OpenWrt:~# uci export dhcp
package dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        list ntp '0.openwrt.pool.ntp.org'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        option start '100'
        option limit '150'
        option leasetime '12h'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'local'
        option interface 'local'
        option start '100'
        option limit '150'
        option leasetime '12h'

config domain
        option name 'www.xxxxxx.me'
        option ip '2001:xxx:xxx:xxx:5400:5ff:fe48:fd6d'

config domain
        option name 'cmcc'
        option ip '192.168.1.1'
root@OpenWrt:~# ifstatus wan6
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 72192,
        "l3_device": "eth0.2",
        "proto": "dhcpv6",
        "device": "eth0.2",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2409:8a62:37d:a3d0::",
                        "mask": 128,
                        "preferred": 187007,
                        "valid": 187007
                },
                {
                        "address": "2409:8a62:37d:a3d0:9abb:99ff:fe4c:e853",
                        "mask": 64,
                        "preferred": 259166,
                        "valid": 259166
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2409:8a62:37d:a3d1::",
                        "mask": 64,
                        "preferred": 100607,
                        "valid": 187007,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "2409:8a62:37d:a3d1::",
                                        "mask": 64
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "2409:8a62:37d:a3d0::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "valid": 259166,
                        "source": "::/0"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::1",
                        "metric": 640,
                        "valid": 3566,
                        "source": "2409:8a62:37d:a3d0:9abb:99ff:fe4c:e853/64"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::1",
                        "metric": 640,
                        "valid": 3566,
                        "source": "2409:8a62:37d:a3d1::/64"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::1",
                        "metric": 640,
                        "valid": 3566,
                        "source": "2409:8a62:37d:a3d0::/128"
                }
        ],
        "dns-server": [
                "fe80::1"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "00170010fe800000000000000000000000000001"
        }
}

root@OpenWrt:~# ifstatus lan
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 71280,
        "l3_device": "br-lan",
        "proto": "static",
        "device": "br-lan",
        "updated": [
                "addresses",
                "routes"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": false,
        "ipv4-address": [
                {
                        "address": "192.168.2.1",
                        "mask": 24
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [
                {
                        "address": "2409:8a62:37d:a3d1::",
                        "mask": 64,
                        "preferred": 99446,
                        "valid": 185846,
                        "local-address": {
                                "address": "2409:8a62:37d:a3d1::1",
                                "mask": 64
                        }
                },
                {
                        "address": "fd50:3eca:ce72::",
                        "mask": 64,
                        "local-address": {
                                "address": "fd50:3eca:ce72::1",
                                "mask": 64
                        }
                }
        ],
        "route": [
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::dee8:90e3:f752:a16",
                        "table": 250,
                        "source": "::/0"
                },
                {
                        "target": "0.0.0.0",
                        "mask": 0,
                        "nexthop": "192.168.1.1",
                        "source": "0.0.0.0/0"
                }
        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}

Remove the gateway and delegate from lan interface.

Add the ra_useleasetime in lan and lower the ra_lifetime

uci set dhcp.lan.ra_useleasetime='1'
uci set dhcp.lan.ra_lifetime='300'
uci commit dhcp
service odhcpd restart

Thanks.
I will try it.
Now just waiting for isp's pd change event occur.