ISP ipv6 “passthrough” setup

I have a question on how or if I can acceive this.
My ISP's router/modem has ipv6 and gets a /64 prefix for connected devices.
That modem is connected to my own router’s wan. So wan get’s an ipv6 from the isp. But since it is a /64 prefix, I can not get ipv6 down to my other interfaces/lan.

Now it seems like the ipv6 given is static. The /64 prefix is displayed on the modem's webpage, so I tried to copy that prefix address and set it as static prefix on my wan interface. The idea is to “clone” the prefix and use it on my lan interface. (What are the odds to randomly get an overlapping address? Lol) As far as I can tell, it does work somewhat. Meaning that my lan interface does pick up the prefix from wan through priority. So in theory, I should be able to have my lan devices receive it. At least the dhcpv6 says it hands out these addresses.

But I run into some other issue, preventing me from properly using the “stolen” v6 subnet. I am not sure what exactly. I have set my router as the dns server (which forwards the requests). My devices pick up their set static address (with suffix). So maybe something is wrong with the shared gateway? On my PC it shows some local fe**:: address. My router is set to use fd**:: addresses, so I assume that it's from the ISP's device.
All I know for sure is that various test sites say I have no ipv6 active.

My lan interface is set to hybrid mode. No master. I previously have tried relay with wan master, but with limited success.

Has anyone some idea what I need to set/change? Or at least what additional info I should post?

Addresses that start with fd are ULAs, they are not routable on the Internet. A public IP (GUA) starts with 2 or 3.

If you do have a GUA /64, v6 relay mode would be the answer. This is common on LTE connections.

1 Like

Oh no no, the device ip is a public 2001:: address.
The gateway is noted as a local fe:: address, which I assume was given by the ISP’s modem/router, since my router is set to hand out fd:: addresses. So my devices have a 2001:: and a fd:: address, and a fe:: gateway address.

Remove the ula_prefix; you don't need it. Then set up relay mode DHCP NDP.

When configured for relay mode the LAN does not actually hold a GUA. LAN devices get GUA within the /64 on wan though. Each time a LAN device appears, a /128 route to it via lan is installed.

1 Like

As I have said in the OP, I have tried setting up relay (following that guide), but it did not work out.
Have I missed some detail perhaps?

Can you DNS and ping v6-only sites from within the router? Do clients get an IP at all? Each active client should have a /128 route in the v6 routing table.


From my pc or tablet I can not reach ipv6 though.
I have setup a 6in4 tunnel, that works. But the speed seems limited to 15mbit. That’s why I am trying to get my ISP given address to work.

As I see this in other topics recently too.... Can we please start and pretend it's 1994 and write networks with their proper cidr notation?

2000::/3 is current GUA
FC::/7 is ULA where FC::/8 is reserved and FD::/8 is available to allocation following the proper allocation schema
Fe80::/10 is LLA

And just for the record, using LLA addresses is just totally fine to be an IPv6 next hop address used in routing tables.

Sorry that I might sound grumpy but this drives me nuts.

If you have troubles to calculate IPv6 cidr like I have then use for instance sipcalc. is a handy lookup table for the special purpose address space too

Check the PC network status that it has a GUA address, gateway (which will be the LLA of the rotuer) and DNS server. Try pinging sites by number as well as by DNS name from the PC.